resharper's cache is empty and code completion does not work

fresh install, latest build, I miss "scanning" dialogs when opening solution, maybe it is related to the fact that we use application templates...

9 comments
Comment actions Permalink

Vaclav,

could you please describe your solution structure in more details. ReSharper
should
work with application template projects.

"Vaclav Kabat" <no_mail@jetbrains.com> wrote in message
news:19077274.1089631364699.JavaMail.itn@is.intellij.net...

fresh install, latest build, I miss "scanning" dialogs when opening
solution, maybe it is related to the fact that we use application
templates...



0
Comment actions Permalink

Please see attached screenshot...it is basically template/folders/projects that are referenced in other projects etc,,,is this going to be enough?



Attachment(s):
jetbrains.JPG
0
Comment actions Permalink

If you open a file in one of those projects, is the file
highlighted without errors? Are there any other unusual effects (except
for broken code completion) that you observe?

"Vaclav Kabat" <no_mail@jetbrains.com> wrote in message
news:9072692.1089632285884.JavaMail.itn@is.intellij.net...

Please see attached screenshot...it is basically template/folders/projects
that are referenced in other projects etc,,,is this going to be enough?



0
Comment actions Permalink

it is not highlighted at all ( I checked and higlighting is enabled, at least in the options windows ..) .. I tried stuff like declaring variable that is not used then etc...

0
Comment actions Permalink

Could you then try to reproduce this problem on a sample application
template solution,
and if you succeed, send us this solution?

"Vaclav Kabat" <no_mail@jetbrains.com> wrote in message
news:19759736.1089633280114.JavaMail.itn@is.intellij.net...

it is not highlighted at all ( I checked and higlighting is enabled, at
least in the options windows ..) .. I tried stuff like declaring variable
that is not used then etc...



0
Comment actions Permalink

created simple one... resharped seemed to work at first but then after I restarted VS.NET stopped working again...



Attachment(s):
Test.zip
0
Comment actions Permalink

Thank you, I'll check it.

"Vaclav Kabat" <no_mail@jetbrains.com> wrote in message
news:18199710.1089635168476.JavaMail.itn@is.intellij.net...

created simple one... resharped seemed to work at first but then after I
restarted VS.NET stopped working again...



0
Comment actions Permalink

I played with it for few more minutes and found out that restructuring solution structure that there are no folders (at least directly under app. template root) helps.. when u do that and restart vs.net, highlighting and everything seems to work.. Unfortunately, I can not do that with real project that I have been working on...

0
Comment actions Permalink

Vaclav,

surely this problem was caused by virtual folders (that folders that contain
nested projects). We've fixed it in build 96. Thank you for your report.

"Vaclav Kabat" <no_mail@jetbrains.com> wrote in message
news:22486761.1089710361660.JavaMail.itn@is.intellij.net...
>I played with it for few more minutes and found out that restructuring
>solution structure that there are no folders (at least directly under app.
>template root) helps.. when u do that and restart vs.net, highlighting and
>everything seems to work.. Unfortunately, I can not do that with real
>project that I have been working on...


0

Please sign in to leave a comment.