Keyboard shortcuts don't work in Chinese versions of VS.NET

There is a problem with automatic keyboard shortcuts setting with Chinese versions of VS.NET,and rest shortcuts don't work. So I add shortcuts manually. :(

3 comments
Comment actions Permalink

There is a problem with automatic keyboard shortcuts setting with Chinese

versions of VS.NET,and rest shortcuts don't work. So I add shortcuts
manually. :(

I had the same issue. I had Visual Studio using keyboard
mappings.

When I installed ReSharper, it gave me an error about default mappings, and
none of the R# keys worked.

I uninstalled resharper completely, setup VS to use my own custom settings
(By copying default settings), then re-installed resharper, and it worked
perfectly


0
Comment actions Permalink

Linux,

automatic keyboard shortcuts setting does not work with localized versions
of VS.NET.
This is a known problem. The reason is that key identifiers in localized
versions of VS.NET are also localized.
ReSharper is only aware of their English names.

"linux_china" <linux_china@hotmail.com> wrote in message
news:24465321.1090653152339.JavaMail.itn@is.intellij.net...

There is a problem with automatic keyboard shortcuts setting with Chinese
versions of VS.NET,and rest shortcuts don't work. So I add shortcuts
manually. :(



0
Comment actions Permalink

I have added shortcuts manually. The attachment is the file for ReSharper shortcuts schema. You can copy it to C:\Documents and Settings\Administrator(your name)\Application Data\Microsoft\VisualStudio\7.1 and use it.
But I can't find shortcut setting for "Extend Selection","Shrink Selection" in shortcut schema. :(



Attachment(s):
ReSharper.vsk
0

Please sign in to leave a comment.