Re# 2 and Read-only files

First of all, even though this is a beta, load speeds seem to be improved for our huge project. Even better, the random 1-2 minute hang (while the disk churns, probably GCing) seems to be gone. Overall I'm liking the new version, looks like a nice improvement (esp. the more extensive code formatting and the team shareable settings and templates). Good job!

My first problem I've encountered is this: our files are readonly due to the source control that we use. When first editing a readonly file, R#2 pops up a dialog asking if I want to modify the file (vs. VS.NET's doing it at save time I believe). Unfortunately I checked the checkbox to not show that dialog any more. Now when I try to edit a readonly file, VS.NET just dings at me. I didn't see any setting in the options dialong or UserSettings.xml, so I'm wondering how I can get back that dialog, or disable this R#2 feature.

Thanks,
- Gyuri

11 comments
Comment actions Permalink

What source control software do you use?

"Gyuri Grell" <no_mail@jetbrains.com> wrote in message
news:6952419.1121882922047.JavaMail.javamailuser@localhost...

First of all, even though this is a beta, load speeds seem to be improved
for our huge project. Even better, the random 1-2 minute hang (while the
disk churns, probably GCing) seems to be gone. Overall I'm liking the new
version, looks like a nice improvement (esp. the more extensive code
formatting and the team shareable settings and templates). Good job!

>

My first problem I've encountered is this: our files are readonly due to
the source control that we use. When first editing a readonly file, R#2
pops up a dialog asking if I want to modify the file (vs. VS.NET's doing
it at save time I believe). Unfortunately I checked the checkbox to not
show that dialog any more. Now when I try to edit a readonly file, VS.NET
just dings at me. I didn't see any setting in the options dialong or
UserSettings.xml, so I'm wondering how I can get back that dialog, or
disable this R#2 feature.

>

Thanks,
- Gyuri



0
Comment actions Permalink

ClearCase. The VS.NET integration was slow from our location, we're using the web service/Eclipse based ClearCase Remote Client (not integrated into VS.NET).

Our workflow is: modify a checked in, readonly file with changes. Save, VS.NET asks if I want to save read-only file, yes. Then in CCRC do a scan for changed files, they're marked as "Hijacked" since I modified them. Check out, check in. If someone modified the file since I last updated my local copy, there'll be a merge at check in time.

Its really not bad once you get used to it (after SourceSafe). The merge feature works quite well, I think it only screwed up once in the two years I've been using it (with many thousands of merges).

- Gyuri

0
Comment actions Permalink

You see, we do not check-out files from the source contrl by ourselves.
Instead, we use VisualStudio' API to communicate eith the source control. So
if you modify some settings there, you should check your source control
integration options, but not the ReSharper' ones

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Gyuri Grell" <no_mail@jetbrains.com> wrote in message
news:6952419.1121882922047.JavaMail.javamailuser@localhost...

First of all, even though this is a beta, load speeds seem to be improved
for our huge project. Even better, the random 1-2 minute hang (while the
disk churns, probably GCing) seems to be gone. Overall I'm liking the new
version, looks like a nice improvement (esp. the more extensive code
formatting and the team shareable settings and templates). Good job!

>

My first problem I've encountered is this: our files are readonly due to
the source control that we use. When first editing a readonly file, R#2
pops up a dialog asking if I want to modify the file (vs. VS.NET's doing
it at save time I believe). Unfortunately I checked the checkbox to not
show that dialog any more. Now when I try to edit a readonly file, VS.NET
just dings at me. I didn't see any setting in the options dialong or
UserSettings.xml, so I'm wondering how I can get back that dialog, or
disable this R#2 feature.

>

Thanks,
- Gyuri



0
Comment actions Permalink

Gyuri,

Thank You for the appreciation of our work.
You may find user settings at C:\Documents and
Settings\<USER-NAME>\Application Data\JetBrains\ReSharper\UserSettings.xml

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

I think you misunderstood what I was saying. We DO NOT use integrated source control; we use an external application. Thus files that are not checked out are read-only. I'm quite sure R#2 hooks into vs.net's handling of read-only files, since it used to let me edit files, then upon saving asked if I want to overwrite the read-only file. Now, R#2 puts up a dialog before I start editing a read-only file asking if I want to edit the file. This R#2 dialog that pops up has a check box to disable the dialog. I checked that, and now I CANNOT edit read-only files. This is a big problem for me, as I almost always start out editing read-only files.

Is there a registry or UserSettings.xml change do either:
a) bring back the R#2 dialog for read-only files?
or b) completely disable R#2's handling of read-only files.


Thanks,
- Gyuri

0
Comment actions Permalink

Sergey,
I am aware of this files, but found no settings in there related to R#2's read-only dialog box.

Any ideas? Perhaps my checking that checkbox passed through to some VS.NET setting?

- Gyuri

0
Comment actions Permalink

Gyuri,

Now I see. We have no such a checkbox. The dialog shown that asks whether
make writable files or not is a VS dialog and we cannot do anything with it.
If You select make writable, then the read-only attribute will be removed
and refactoring continues. But You'll have to check out (and possibly merge)
file from Your version control manually.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Gyuri Grell" <no_mail@jetbrains.com> wrote in message
news:26443505.1121953479636.JavaMail.javamailuser@localhost...


0
Comment actions Permalink

OK, you are right, it is a VS.NET dialog. But something in the R#2 install must have enabled that dialog, because I've never seen it, this is on a fresh install of VS.NET. Thats why I was confused and thought it was a R#2 dialog. This is now on two computers (I tested it first on my old laptop).

- Gyuri

0
Comment actions Permalink

OK, I think I figured it out. On my old machine, I have R#2 installed, and get that dialog when trying to edit a read-only file (never got it before R#2 was installed). According to VS.NET help:
-


To change your Visual Studio configuration to allow read-only files to be edited

On the Tools menu, click Options.
In the Environment folder, click Documents.
Click Allow editing of read-only files, warn when attempt to save, and then click OK.
-


So I went ahead and uninstalled R#2; lo and behold, I no longer get the source control dialog asking if I want to edit the read-only file. It looks like when R#2 is installed, the "Allow editing of read-only files" setting is ignored. I'm guessing you must be using the integrated source control there and that why you didn't notice. I'm not using integrated source control, I'm using an external app.

Thanks,
- Gyuri

0
Comment actions Permalink

Great. I think we'll set this option at install time.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Its on by default in a base VS.NET install, so something in R# might be preventing it from being recognized.

0

Please sign in to leave a comment.