Stop Resharper 2.0 from loading automtically

Is there anyway to stop Resharper 2.0 from loading automatically in VS 2005
? Resharper is throwing up a lot of exceptions in a solution with asp.net
website, I want to use Resharper in other solutions but not in one that has
asp.net pages. Is this possible ? I tried not to load Resharper on startup
through the add-in manager but that does not seem to be working

Thanks


4 comments
Comment actions Permalink

Along these lines,
It would be nice to:
1. Tie loading of Resharper to specific solution. For example, I have a
large build all project and I don't want to wait for it to load. I don't
want to disable the add-in every time I change projects.
2. Have a cancel button on the loading progress dialog to stop loading.
Thanks.

"Krishna" <k@y.com> wrote in message news:dboh2t$2g6$1@is.intellij.net...

Is there anyway to stop Resharper 2.0 from loading automatically in VS
2005 ? Resharper is throwing up a lot of exceptions in a solution with
asp.net website, I want to use Resharper in other solutions but not in one
that has asp.net pages. Is this possible ? I tried not to load Resharper
on startup through the add-in manager but that does not seem to be working

>

Thanks



0
Comment actions Permalink

I am not sure about 2005 but in 2003 I found that if I disable R# completely in Tools | Addin Manager then it does not load until I hit one of the shortcut keys (E.G. Ctrl+B). Then R# loads. I have found this very useful when I am carrying out VS tasks that do not need R# (like altering project settings).

0
Comment actions Permalink

Krishna,

Is there anyway to stop Resharper 2.0 from loading automatically in VS
2005 ? Resharper is throwing up a lot of exceptions in a solution with
asp.net website, I want to use Resharper in other solutions but not in one
that has asp.net pages. Is this possible ?

Have You submitted them to the bugtracker? I have already fixed a couple of
ASP exceptions and hope the next build will be much more stable.

I tried not to load Resharper on startup through the add-in manager but
that does not seem to be working

Right now, the only way to stop R# is to uncheck 'run on startup' option in
Tools->Add-in Manager. In, fact, You'd better uncheck all the checkboxes.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Thanks I would try that. I did try submitting the exceptions to the tracker
from the dialog that poped up. Looking forward to the next build :)

"Sergey V. Coox" <qx@intellij.com> wrote in message
news:dbqcet$4vl$1@is.intellij.net...

Krishna,

>
>
>> Is there anyway to stop Resharper 2.0 from loading automatically in VS
>> 2005 ? Resharper is throwing up a lot of exceptions in a solution with
>> asp.net website, I want to use Resharper in other solutions but not in
>> one that has asp.net pages. Is this possible ?

Have You submitted them to the bugtracker? I have already fixed a couple
of ASP exceptions and hope the next build will be much more stable.

>
>> I tried not to load Resharper on startup through the add-in manager but
>> that does not seem to be working

Right now, the only way to stop R# is to uncheck 'run on startup' option
in Tools->Add-in Manager. In, fact, You'd better uncheck all the
checkboxes.

>

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0

Please sign in to leave a comment.