Memory usage and devenv.exe not exiting

I have the following problem with build 165 and 202 and VS2003.
In both cases opening a solution containing several projects causes devenv.exe to use 120/120Mb Mem Usage/VM Size (more in build 202 maybe 160/230Mb) as reported by Task Manager.
I can live with that (sort of), but when I exit DevStudio, devenv.exe nearly always gets stuck in memory, and keeps using loads of memory and 1 thread. If I turn off Resharper then this doesn't happen. This is getting very annoying.

Has anyone else experienced this problem?

1 comment
Comment actions Permalink

Philip Lee wrote:

I have the following problem with build 165 and 202 and VS2003.
In both cases opening a solution containing several projects causes devenv.exe to use 120/120Mb Mem Usage/VM Size (more in build 202 maybe 160/230Mb) as reported by Task Manager.
I can live with that (sort of), but when I exit DevStudio, devenv.exe nearly always gets stuck in memory, and keeps using loads of memory and 1 thread. If I turn off Resharper then this doesn't happen. This is getting very annoying.

Has anyone else experienced this problem?


sometimes i have the same problem with build 165. I'm working on a solution with around 7.000 classes spread over 10 projects. The
memory consumption of VS is up to 1 GB virtual size (even without R#). Sometimes Devenv.exe doesn't shutdown correctly. The
behaviour is not reproducible for me. I agree that this doesn't occur when i deactivate or deinstall R#.

Regards
Klaus

0

Please sign in to leave a comment.