[R#205 VS2003] Test Runner Problems

I am unable to run a single NUnit test in my solution. When I try to run
or debug the test, I get the message:

-



-


Cannot load test tree from assembly.
-


OK
-



I can run the tests with no problems from the NUnit gui. Any suggestions
on what to do here? What other information can I provide to help?

Thanks,
Derek


5 comments
Comment actions Permalink

Should I just enter this into the tracker?

DP> I am unable to run a single NUnit test in my solution. When I try
DP> to run or debug the test, I get the message:
DP>
DP> -


DP>
DP> -


DP> Cannot load test tree from assembly.
DP> -


DP> OK
DP> -


DP> I can run the tests with no problems from the NUnit gui. Any
DP> suggestions on what to do here? What other information can I
DP> provide to help?
DP>
DP> Thanks,
DP> Derek


0
Comment actions Permalink

Posting this request into tracker will not help us to investigate the
problem.
Did you have successfull expirience with our UnittestRunner before, or it
haven't been working at you side forever?

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Derek Price" <derek.price@gmail.com> wrote in message
news:71a7df64aca0a8c77c20668f5a34@news.intellij.net...

Should I just enter this into the tracker?

>

DP> I am unable to run a single NUnit test in my solution. When I try
DP> to run or debug the test, I get the message:
DP> DP> ---------------------------
DP> DP> ---------------------------
DP> Cannot load test tree from assembly.
DP> ---------------------------
DP> OK
DP> ---------------------------
DP> I can run the tests with no problems from the NUnit gui. Any
DP> suggestions on what to do here? What other information can I
DP> provide to help?
DP> DP> Thanks,
DP> Derek

>



0
Comment actions Permalink

Hello Eugene,

I was very successful in the previous version 204. I have another post on
August 19th where I was getting a socket exception, but I no longer get this
at all. Just the "Cannot load test tree from assembly." message. Is there
anything I can do to debug or log something for you?

I used to use TestDriven.net (it's un-installed) and this was awesome when
it was working. I've very humbled to be back in NUnit again...

Thanks,
Derek

EP> Posting this request into tracker will not help us to investigate
EP> the
EP> problem.
EP> Did you have successfull expirience with our UnittestRunner before,
EP> or it
EP> haven't been working at you side forever?


0
Comment actions Permalink

I just opened the solution and rebuilt and now the test runner is working!
I still think something is not quite right considering the two separate
messages I've seen. Is there a debug switch I can turn on to help log any
issues?

Thanks

DP> Hello Eugene,
DP>
DP> I was very successful in the previous version 204. I have another
DP> post on August 19th where I was getting a socket exception, but I no
DP> longer get this at all. Just the "Cannot load test tree from
DP> assembly." message. Is there anything I can do to debug or log
DP> something for you?
DP>
DP> I used to use TestDriven.net (it's un-installed) and this was
DP> awesome when it was working. I've very humbled to be back in NUnit
DP> again...
DP>
DP> Thanks,
DP> Derek
EP>> Posting this request into tracker will not help us to investigate
EP>> the
EP>> problem.
EP>> Did you have successfull expirience with our UnittestRunner before,
EP>> or it
EP>> haven't been working at you side forever?


0
Comment actions Permalink

No, there are no any debug mode currently available.
I'll think on introducing some verbose to help solve thisproblems in the
future....

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Derek Price" <derek.price@gmail.com> wrote in message
news:71a7df64afdb38c77c50d027c05a@news.intellij.net...
>I just opened the solution and rebuilt and now the test runner is working!
>I still think something is not quite right considering the two separate
>messages I've seen. Is there a debug switch I can turn on to help log any
>issues?
>

Thanks

>

DP> Hello Eugene,
DP> DP> I was very successful in the previous version 204. I have another
DP> post on August 19th where I was getting a socket exception, but I no
DP> longer get this at all. Just the "Cannot load test tree from
DP> assembly." message. Is there anything I can do to debug or log
DP> something for you?
DP> DP> I used to use TestDriven.net (it's un-installed) and this was
DP> awesome when it was working. I've very humbled to be back in NUnit
DP> again...
DP> DP> Thanks,
DP> Derek
EP>> Posting this request into tracker will not help us to investigate
EP>> the
EP>> problem.
EP>> Did you have successfull expirience with our UnittestRunner before,
EP>> or it
EP>> haven't been working at you side forever?

>



0

Please sign in to leave a comment.