Surround With deleting text

I select a region for surrounding, then select ReSharper -> Code -> Surround
With (I'm having keyboard shortcut problems). The popup menu appears, then
I select the number for any option and my highlighted text disappears and is
replaced by the number, instead of the entire selected region being
surrounded with the selected option.

Suggestions?


4 comments
Comment actions Permalink

Hello Jim,

Are you using the latest build?

Oleg Stepanov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I select a region for surrounding, then select ReSharper -> Code ->
Surround With (I'm having keyboard shortcut problems). The popup menu
appears, then I select the number for any option and my highlighted
text disappears and is replaced by the number, instead of the entire
selected region being surrounded with the selected option.

Suggestions?



0
Comment actions Permalink

Yes. 205.

"Oleg Stepanov (JetBrains)" <Oleg.Stepanov@JetBrains.Com> wrote in message
news:55e774163561898c780f0c6a24ee9@news.intellij.net...

Hello Jim,

>

Are you using the latest build?

>

Oleg Stepanov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> I select a region for surrounding, then select ReSharper -> Code ->
>> Surround With (I'm having keyboard shortcut problems). The popup menu
>> appears, then I select the number for any option and my highlighted
>> text disappears and is replaced by the number, instead of the entire
>> selected region being surrounded with the selected option.
>>
>> Suggestions?
>>
>



0
Comment actions Permalink

This appears to be self-inflicted. I was importing the keyboard settings
file under \Program Files instead of my homedir's Application Settings.

I'm using the correct settings file and surround with is working fine now.


"Oleg Stepanov (JetBrains)" <Oleg.Stepanov@JetBrains.Com> wrote in message
news:55e774163561898c780f0c6a24ee9@news.intellij.net...

Hello Jim,

>

Are you using the latest build?

>

Oleg Stepanov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> I select a region for surrounding, then select ReSharper -> Code ->
>> Surround With (I'm having keyboard shortcut problems). The popup menu
>> appears, then I select the number for any option and my highlighted
>> text disappears and is replaced by the number, instead of the entire
>> selected region being surrounded with the selected option.
>>
>> Suggestions?
>>
>



0
Comment actions Permalink

Hello Jim,

Great!

Oleg Stepanov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

This appears to be self-inflicted. I was importing the keyboard
settings file under \Program Files instead of my homedir's Application
Settings.

I'm using the correct settings file and surround with is working fine
now.

"Oleg Stepanov (JetBrains)" <Oleg.Stepanov@JetBrains.Com> wrote in
message news:55e774163561898c780f0c6a24ee9@news.intellij.net...

>> Hello Jim,
>>
>> Are you using the latest build?
>>
>> Oleg Stepanov
>> Software Developer
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I select a region for surrounding, then select ReSharper -> Code ->
>>> Surround With (I'm having keyboard shortcut problems). The popup
>>> menu appears, then I select the number for any option and my
>>> highlighted text disappears and is replaced by the number, instead
>>> of the entire selected region being surrounded with the selected
>>> option.
>>>
>>> Suggestions?
>>>


0

Please sign in to leave a comment.