Local highlighting and alt-enter mapping

I was a heavy tester of Resharper back in pre 1.0 days, and I'm back with the EAP for 2005 :)

First issue is that resharper is giving a teal background to all of my local variables. I've tried to disable it, butthe only way I've found so far is to go in Options --> Highlighting and disable "Enable Highlighting". Strangely, if I make each entry "Do not show" it's still doing it, so it isn't one of the highlighting rules doing it.

Also, my alt-enter doesn't work..it keeps making my property window zoom into and out of focus shrug

4 comments
Comment actions Permalink

I'm having the same problems.

Also, sometimes i get Resharper and VS intellisense completion lists at the same time. Sometimes I manage to disable VS items but in some projects it keeps coming back.

It would be nice if there were a note describing how VS should be configured (besides loading the key mapping).

Also, I have no idea how to get alt-enter instead of alt-shift-f10 to get back "usings" etc.

0
Comment actions Permalink

Hello karl,

please see inline.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I was a heavy tester of Resharper back in pre 1.0 days, and I'm back
with the EAP for 2005 :)

First issue is that resharper is giving a teal background to all of my
local variables. I've tried to disable it, butthe only way I've found
so far is to go in Options --> Highlighting and disable "Enable
Highlighting". Strangely, if I make each entry "Do not show" it's
still doing it, so it isn't one of the highlighting rules doing it.


This is a known bug in VS 2005. MS promised us to address it in a redistributable
hotfix which will be included in ReSharper's installation.


Also, my alt-enter doesn't work..it keeps making my property window
zoom into and out of focus shrug


Not sure about this, but could you please check what VS command the Alt+Enter
shortcut
is currently assigned to?


0
Comment actions Permalink

Hello Hartmut,

to disable VS intellisense you can use an option on the
Tools|Options|Text Editor|C# page. I'm not sure why it
comes back in some projects once disabled, may it be just an
issue of not saving changed VS options e.g. because of a VS crash?

In near future ReSharper will disable VS intellisense when its own completion
is enabled. Ideally, all configuration except for installation of key mappings
should
be done automatically, but I think it's indeed a good idea to have a document
describing
VS's configuration process, although all the issues are actually covered
in FAQ.

Regarding problems with key mappings, you can always manually change them
using Tools|Options|Environment|Keyboard.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm having the same problems.

Also, sometimes i get Resharper and VS intellisense completion lists
at the same time. Sometimes I manage to disable VS items but in some
projects it keeps coming back.

It would be nice if there were a note describing how VS should be
configured (besides loading the key mapping).

Also, I have no idea how to get alt-enter instead of alt-shift-f10 to
get back "usings" etc.



0
Comment actions Permalink

It's currently assigned to:
ClassViewContextMenus.ClassViewProject.Properties

I removed the assignment, but alt-Enter still doesn't do the Resharper action (even though the tooltip says it's alt-enter).

I looked through the resharper keyboard commands, but didn't come across what I thought was right. Is there a command I should bind alt-enter to?

0

Please sign in to leave a comment.