Reshaper lost all settings

This morning resharper lost all it's settings. This is on buid 209. All formatting options, live templates, surround with, you name it.

I was playing with (deleting and stuff) files in:
\Microsoft Visual Studio 8\Common7\IDE\ItemTemplatesCache
and
\Microsoft Visual Studio 8\Common7\IDE\ItemTemplates

I also started 2003 (which still has the non-EAP installed).

Are either of those known to cause data wipes?

Off to install 210

3 comments
Comment actions Permalink

karl wrote:

This morning resharper lost all it's settings. This is on buid 209. All formatting options, live templates, surround with, you name it.

I was playing with (deleting and stuff) files in:
\Microsoft Visual Studio 8\Common7\IDE\ItemTemplatesCache
and
\Microsoft Visual Studio 8\Common7\IDE\ItemTemplates

I also started 2003 (which still has the non-EAP installed).

Are either of those known to cause data wipes?

Off to install 210


I had the same problem the other way around.. every time I used VS2005,
the ReSharper settings for VS2003 were gone. Do they use the same
UserConfig.xml?

Max

0
Comment actions Permalink

Markus,

I had the same problem the other way around.. every time I used VS2005,
the ReSharper settings for VS2003 were gone. Do they use the same
UserConfig.xml?


Absolutely. Unfortunately, R# for VS2003 and VS2005 uses the same file
\]]>\Application
Data\JetBrains\ReSharper\UserSettings.xml

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

I had the same problem the other way around.. every time I used
VS2005, the ReSharper settings for VS2003 were gone. Do they use the
same UserConfig.xml?


They do but I cannot understand how this can cause loosing the settings.
Is it reproducable?

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

karl wrote:

>> This morning resharper lost all it's settings. This is on buid 209.
>> All formatting options, live templates, surround with, you name it.
>>
>> I was playing with (deleting and stuff) files in:
>> \Microsoft Visual Studio 8\Common7\IDE\ItemTemplatesCache
>> and
>> \Microsoft Visual Studio 8\Common7\IDE\ItemTemplates
>> I also started 2003 (which still has the non-EAP installed).
>>
>> Are either of those known to cause data wipes?
>>
>> Off to install 210
>>

I had the same problem the other way around.. every time I used
VS2005, the ReSharper settings for VS2003 were gone. Do they use the
same UserConfig.xml?

Max



0

Please sign in to leave a comment.