IntelliSense problem in 209

I have problem with IntelliSense in Build 209. I am using 'Auto-popup after
a character is typed' option and for example when I'm typing "stri" instead
of expected "string" I have a longer ones first on the list or if I'm
typing "fore" instead of "foreach" firs on the list I have
"ForeignKeyConstraint".



Second annoying thing is that there is no special words like "if', "int",
"for".

I'm typing "if" pressing space and it's shows "IFormattable" and I just want
"if"!



Please tell mi if there is something wrong with my settings or it's
resharper bug?



Pitter


6 comments
Comment actions Permalink

Hello Pitter,

If you want the completion to suggest short keywords open the ReSharper/Options/Code
Completion page and set the Include keywords longer than 3 characters to
1. That will make ReSharper suggest all keywords.

I have problem with IntelliSense in Build 209. I am using 'Auto-popup
after a character is typed' option and for example when I'm typing
"stri" instead of expected "string" I have a longer ones first on the
list or if I'm typing "fore" instead of "foreach" firs on the list I
have "ForeignKeyConstraint".

Second annoying thing is that there is no special words like "if',
"int", "for".

I'm typing "if" pressing space and it's shows "IFormattable" and I
just want "if"!

Please tell mi if there is something wrong with my settings or it's
resharper bug?

Pitter

Thanks,
Andrey Simanovsky


0
Comment actions Permalink

It's a known problem and is fixed in the build #210.

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have problem with IntelliSense in Build 209. I am using 'Auto-popup
after a character is typed' option and for example when I'm typing
"stri" instead of expected "string" I have a longer ones first on the
list or if I'm typing "fore" instead of "foreach" firs on the list I
have "ForeignKeyConstraint".

Second annoying thing is that there is no special words like "if',
"int", "for".

I'm typing "if" pressing space and it's shows "IFormattable" and I
just want "if"!

Please tell mi if there is something wrong with my settings or it's
resharper bug?

Pitter



0
Comment actions Permalink

It would be also very useful if after typing "override" R# would suggest
list of members that can be overridden.



One more thing with R# intellisens is that it does not work with class
diagrams. The intellisens does not work when you specify types of members in
class detail window.


0
Comment actions Permalink

+1

"Piotr Zbyszyñski" <styko@atos.wmid.amu.edu.pl> wrote in message
news:dlf1i4$5v8$1@is.intellij.net...

It would be also very useful if after typing "override" R# would suggest
list of members that can be overridden.

>
>
>

One more thing with R# intellisens is that it does not work with class
diagrams. The intellisens does not work when you specify types of members
in class detail window.

>



0
Comment actions Permalink

Could you please post this suggestion into the tracker? It's a good one and
maybe we will implement it for ReSharper 2.x.

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

It would be also very useful if after typing "override" R# would
suggest list of members that can be overridden.

One more thing with R# intellisens is that it does not work with class
diagrams. The intellisens does not work when you specify types of
members in class detail window.



0
Comment actions Permalink

Could you please post this suggestion into the tracker? It's a good one
and maybe we will implement it for ReSharper 2.x.

done


0

Please sign in to leave a comment.