"Initializer is not used" inspection

Is there a way to disable this inspection? I could not find it in the Highlighing options list.

Thanks

Todd

3 comments
Comment actions Permalink

No, currently this warning couldn't be disabled.
I will add the corresponding option.

BTW, why do you need to disable this warning, but not to alter the code to
remove redundant assignment?

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Todd Breiholz" <no_mail@jetbrains.com> wrote in message
news:20299801.1134580960130.JavaMail.itn@is.intellij.net...

Is there a way to disable this inspection? I could not find it in the
Highlighing options list.

>

Thanks

>

Todd



0
Comment actions Permalink

Eugene

No good reason, really. I intend to fix them eventually. Just a bunch of legacy code, and I'd like to hide that particular warning until I'm ready to deal with it.

Thanks for the reply.

Todd

0
Comment actions Permalink

Seems like this is another candidate for a "batch fix" type thing. Usually
when this happens, it happens a lot, and having to click and "quick fix"
each one individually is tiresome and tedious. If there were an option to
"fix all in this source file", that would be really nice.

"Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:dnr3s5$ing$1@is.intellij.net...

No, currently this warning couldn't be disabled.
I will add the corresponding option.

>

BTW, why do you need to disable this warning, but not to alter the code to
remove redundant assignment?

>

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Todd Breiholz" <no_mail@jetbrains.com> wrote in message
news:20299801.1134580960130.JavaMail.itn@is.intellij.net...

>> Is there a way to disable this inspection? I could not find it in the
>> Highlighing options list.
>>
>> Thanks
>>
>> Todd
>



0

Please sign in to leave a comment.