Color problems again

Hello,

My completion replacement color was again reset to black-on-black. Very annoying
=((
But this time I even cannot find the corresponding color setting. Moreover,
all "Resharper" color settings are gone. It this a bug or a feature?

Best regards,
Maxim



9 comments
Comment actions Permalink

Hello Maxim,

run 'devenv.exe /setup' from the command line and the problem should go away
(make sure to wait
its completion - it takes a while). Concerning your
question if this is a bug or feature - I'd say this is a problem. The 'devenv.exe
/setup' should be invoked
during installation (and it gets invoked) but for some reason this don't
work always.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello,

My completion replacement color was again reset to black-on-black.
Very annoying
=((
But this time I even cannot find the corresponding color setting.
Moreover,
all "Resharper" color settings are gone. It this a bug or a feature?
Best regards,
Maxim



0
Comment actions Permalink

Hello Dmitry,

Hello Maxim,

run 'devenv.exe /setup' from the command line and the problem should
go away

Unfortunately, I does not. No new color settings have appeared.

I also tried to reinstall Resharper, but no luck.

(make sure to wait its completion - it takes a while).

Hm... for me it takes about 3-4 seconds to complete.

Actually, I was already reporting a problem with black-on-black colors. And
that issue was occuring in VS2003 as well.

Regards,
Maxim


0
Comment actions Permalink

Hello Maxim,

have you recently installed any other extensions for VS?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Dmitry,

>> Hello Maxim,
>>
>> run 'devenv.exe /setup' from the command line and the problem should
>> go away
>>

Unfortunately, I does not. No new color settings have appeared.

I also tried to reinstall Resharper, but no luck.

>> (make sure to wait its completion - it takes a while).
>>

Hm... for me it takes about 3-4 seconds to complete.

Actually, I was already reporting a problem with black-on-black
colors. And that issue was occuring in VS2003 as well.

Regards,
Maxim



0
Comment actions Permalink

Hello Dmitry,

have you recently installed any other extensions for VS?

No.

Do you need to see the content of some of my registry keys?

Best regards,
Maxim



0
Comment actions Permalink

Hello Maxim,

Aha! I found those Resharper settings! But they are only visible when I set
'Show settings for' to 'Printer'. Why so?

Best regards,
Maxim



0
Comment actions Permalink

Hello Maxim,

yes, I'm seeing the same with the latest dev. build. No idea why it happens
:( - will investigate & fix it ASAP.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Maxim,

Aha! I found those Resharper settings! But they are only visible when
I set 'Show settings for' to 'Printer'. Why so?

Best regards,
Maxim



0
Comment actions Permalink

Hello Dmitry,

Hello Maxim,

yes, I'm seeing the same with the latest dev. build. No idea why it
happens :( - will investigate & fix it ASAP.

OK, thanks.... Please, keep us informed -- reading text which is displayed
as black-over-black is really frustrating ;)

Best regards,
Maxim



0
Comment actions Permalink

Hello Maxim,

unfortunately it appears that the problem is more complex that I thought
initially - when I launch VS,
I sometimes see ReSharper entries in Fonts and Colors, sometimes I don't
see them. Not sure what my
actions make the difference. Also some my colleagues
don't have this problems with 213 and the latest builds. We'll continue investigating
but I don't promise
immediate results. So currently we have 3 actions that affect the problem:

1) reinstall ReSharper (first uninstall, then install)
2) run 'devenv.exe /setup'
3) Reset all settings (Tools|Import and Export Settings...)

I realize that you've tried 1) and 2) Please also try 3), then 2) and check
if it helps.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Dmitry,

>> Hello Maxim,
>>
>> yes, I'm seeing the same with the latest dev. build. No idea why it
>> happens :( - will investigate & fix it ASAP.
>>

OK, thanks.... Please, keep us informed -- reading text which is
displayed as black-over-black is really frustrating ;)

Best regards,
Maxim



0
Comment actions Permalink

Hello Dmitry,

I did 3) and 2) (in this order) and it helped me. Thanks a lot.

Best regards,
Maxim



0

Please sign in to leave a comment.