Bracket Reformatting

Greetings,

I've installed the latest version of Resharper 1.5.1, and cannot get the
brackets to format properly. If I type in:

if ( Some_Cool_Condition ) {
Do.Something( Cool );
} else {
Do.Something( NotCool );
}//if

It will reformat it to:

if ( Some_Cool_Condition )
}
Do.Something( Cool );
}
else
{
Do.Something( NotCool );
}//if

In Options, I have set the braces layout to "At End of Line" for all
three of the items, which should keep the formating consistent with the
items above, but cannot get it to stick.

I'm actually recovering from a hard-drive failure and have copied
previous specified options after re-installing. Is it possible I'm
encounter some kind of issue that way?

Any suggestions?

Thanks,
- Ian

3 comments
Comment actions Permalink

Hello Ian,

Do not know actually how to fix your issue but you're obviously asking in
a wrong newsgroup. jetbrains.resharper.eap is devoted to EAP builds of Resharper
2.0.

Best regards,
Maxim



0
Comment actions Permalink

I've reposted the message elsewhere.

The new JetBrains wiki is a bit confusing to try and find what you need.

Thanks
- Ian

Maxim Babenko wrote:

Hello Ian,

Do not know actually how to fix your issue but you're obviously asking
in a wrong newsgroup. jetbrains.resharper.eap is devoted to EAP builds
of Resharper 2.0.

Best regards,
Maxim


0
Comment actions Permalink

I believe support@jetbrains.com is the best place to report issues about
released versions of ReSharper.
Alternatively, you can use jetbrains.resharper.community newsgroup.

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Greetings,

I've installed the latest version of Resharper 1.5.1, and cannot get
the brackets to format properly. If I type in:

if ( Some_Cool_Condition ) {
Do.Something( Cool );
} else {
Do.Something( NotCool );
}//if
It will reformat it to:

if ( Some_Cool_Condition )
}
Do.Something( Cool );
}
else
{
Do.Something( NotCool );
}//if
In Options, I have set the braces layout to "At End of Line" for all
three of the items, which should keep the formating consistent with
the items above, but cannot get it to stick.

I'm actually recovering from a hard-drive failure and have copied
previous specified options after re-installing. Is it possible I'm
encounter some kind of issue that way?

Any suggestions?

Thanks,
- Ian



0

Please sign in to leave a comment.