[211] Unit Test Runner Freezing

Have you guys been made aware of the freezing of the unit test runner? I
get it freezing randomly in the following scenarios:

- First time use since opening VS.NET, freezes after 100% bar on
"Loading Assembly.." when running a test
- When tests are finished or running, clicking to the "Failed" tab on
the left side occasionally locks up VS.NET completely.

8 comments
Comment actions Permalink

I have seen the same thing. I am glad that someone else is seeing it as
well.

I searched through the issue tracker and found two issues (10687, 11757)
that seem to be about the same type of issue. Both issues are marked
fixed, so either this is a different situation or the bugs are not fixed
completely.

What type of info can I provide the next time that this occurs that will
assist JetBrains in fixing this? Also, it appears to be random, but
maybe I haven't seen the pattern yet.


Greg Fodor wrote:

Have you guys been made aware of the freezing of the unit test runner? I
get it freezing randomly in the following scenarios:

- First time use since opening VS.NET, freezes after 100% bar on
"Loading Assembly.." when running a test
- When tests are finished or running, clicking to the "Failed" tab on
the left side occasionally locks up VS.NET completely.

0
Comment actions Permalink

Hello Jason,

I think the greatest help would be to capture the state of the hung process
using the debugger.
That is, when this happens next time, attach a debugger to the hung devenv.exe,
copy stack
traces of all managed threads (use 'Threads' and 'Call Stack' debugging views)
and post them here.

Thanks in advance.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have seen the same thing. I am glad that someone else is seeing it
as well.

I searched through the issue tracker and found two issues (10687,
11757) that seem to be about the same type of issue. Both issues are
marked fixed, so either this is a different situation or the bugs are
not fixed completely.

What type of info can I provide the next time that this occurs that
will assist JetBrains in fixing this? Also, it appears to be random,
but maybe I haven't seen the pattern yet.

Greg Fodor wrote:

>> Have you guys been made aware of the freezing of the unit test
>> runner? I get it freezing randomly in the following scenarios:
>>
>> - First time use since opening VS.NET, freezes after 100% bar on
>> "Loading Assembly.." when running a test
>> - When tests are finished or running, clicking to the "Failed" tab on
>> the left side occasionally locks up VS.NET completely.


0
Comment actions Permalink

Strangely enough, when I try to attach a VS.NET 2005 debugger to the
hung VS.NET 2003 process, it unfreezes it and starts to work!?

-Greg

Dmitry Shaporenkov (JetBrains) wrote:

Hello Jason,

I think the greatest help would be to capture the state of the hung
process using the debugger.
That is, when this happens next time, attach a debugger to the hung
devenv.exe, copy stack
traces of all managed threads (use 'Threads' and 'Call Stack' debugging
views) and post them here.

Thanks in advance.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I have seen the same thing. I am glad that someone else is seeing it
>> as well.
>>
>> I searched through the issue tracker and found two issues (10687,
>> 11757) that seem to be about the same type of issue. Both issues are
>> marked fixed, so either this is a different situation or the bugs are
>> not fixed completely.
>>
>> What type of info can I provide the next time that this occurs that
>> will assist JetBrains in fixing this? Also, it appears to be random,
>> but maybe I haven't seen the pattern yet.
>>
>> Greg Fodor wrote:
>>
>>> Have you guys been made aware of the freezing of the unit test
>>> runner? I get it freezing randomly in the following scenarios:
>>>
>>> - First time use since opening VS.NET, freezes after 100% bar on
>>> "Loading Assembly.." when running a test
>>> - When tests are finished or running, clicking to the "Failed" tab on
>>> the left side occasionally locks up VS.NET completely.


0
Comment actions Permalink

Hello Greg,

I have been doing the same thing and getting the same result (but attaching a new VS2003 to the hung VS2003) - either that or they both seem to hang.
I did get one useful part of a screenshot from within an attached debugger once though (attached).

Ronnie

Strangely enough, when I try to attach a VS.NET 2005 debugger to the
hung VS.NET 2003 process, it unfreezes it and starts to work!?

-Greg

Dmitry Shaporenkov (JetBrains) wrote:

>> Hello Jason,
>>
>> I think the greatest help would be to capture the state of the hung
>> process using the debugger.
>> That is, when this happens next time, attach a debugger to the hung
>> devenv.exe, copy stack
>> traces of all managed threads (use 'Threads' and 'Call Stack'
>> debugging
>> views) and post them here.
>> Thanks in advance.
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I have seen the same thing. I am glad that someone else is seeing
>>> it as well.
>>>
>>> I searched through the issue tracker and found two issues (10687,
>>> 11757) that seem to be about the same type of issue. Both issues
>>> are marked fixed, so either this is a different situation or the
>>> bugs are not fixed completely.
>>>
>>> What type of info can I provide the next time that this occurs that
>>> will assist JetBrains in fixing this? Also, it appears to be
>>> random, but maybe I haven't seen the pattern yet.
>>>
>>> Greg Fodor wrote:
>>>
>>>> Have you guys been made aware of the freezing of the unit test
>>>> runner? I get it freezing randomly in the following scenarios:
>>>>
>>>> - First time use since opening VS.NET, freezes after 100% bar on
>>>> "Loading Assembly.." when running a test
>>>> - When tests are finished or running, clicking to the "Failed" tab
>>>> on
>>>> the left side occasionally locks up VS.NET completely.



Attachment(s):
1.png
0
Comment actions Permalink

Hello Ronnie,

unfortunately, there's nothing strange in the attached screenshot - this
is just a dedicated
thread that runs permanently when the solution is opened. The hang likely
happens, because the primary thread is waiting for something or busy doing
something...


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Greg,

I have been doing the same thing and getting the same result (but
attaching a new VS2003 to the hung VS2003) - either that or they both
seem to hang.

I did get one useful part of a screenshot from within an attached
debugger once though (attached).

Ronnie

>> Strangely enough, when I try to attach a VS.NET 2005 debugger to the
>> hung VS.NET 2003 process, it unfreezes it and starts to work!?
>>
>> -Greg
>>
>> Dmitry Shaporenkov (JetBrains) wrote:
>>
>>> Hello Jason,
>>>
>>> I think the greatest help would be to capture the state of the hung
>>> process using the debugger.
>>> That is, when this happens next time, attach a debugger to the hung
>>> devenv.exe, copy stack
>>> traces of all managed threads (use 'Threads' and 'Call Stack'
>>> debugging
>>> views) and post them here.
>>> Thanks in advance.
>>> Regards,
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> I have seen the same thing. I am glad that someone else is seeing
>>>> it as well.
>>>>
>>>> I searched through the issue tracker and found two issues (10687,
>>>> 11757) that seem to be about the same type of issue. Both issues
>>>> are marked fixed, so either this is a different situation or the
>>>> bugs are not fixed completely.
>>>>
>>>> What type of info can I provide the next time that this occurs that
>>>> will assist JetBrains in fixing this? Also, it appears to be
>>>> random, but maybe I haven't seen the pattern yet.
>>>>
>>>> Greg Fodor wrote:
>>>>
>>>>> Have you guys been made aware of the freezing of the unit test
>>>>> runner? I get it freezing randomly in the following scenarios:
>>>>>
>>>>> - First time use since opening VS.NET, freezes after 100% bar on
>>>>> "Loading Assembly.." when running a test
>>>>> - When tests are finished or running, clicking to the "Failed" tab
>>>>> on
>>>>> the left side occasionally locks up VS.NET completely.


0
Comment actions Permalink

"Greg Fodor" <greg@parature.com> schrieb im Newsbeitrag
news:do9ofc$dqs$1@is.intellij.net...

Strangely enough, when I try to attach a VS.NET 2005 debugger to the hung
VS.NET 2003 process, it unfreezes it and starts to work!?


same here! It's enough to even start the DbgCLR.EXE and VS2003 is unfreezed.


Sincerely,
Stefan Lieser


0
Comment actions Permalink

Hi,

today I found another way to unfreeze the unit test runner: click the "Show
desktop" icon in the task bar (I hope it is named so in the english windows
version becaus I use the german one; it's the icon that iconifies all
windows to show the desktop). It unfreezes most of the time....


Sincerely,
Stefan Lieser


0
Comment actions Permalink

Hello Stefan,

Wow, you know - he's right!
I really didn't expect that to work...
There must be a redraw loop stuck somewhere - it's right at the end of the
progress bar when 'exploring assemblies' that I just had a hang - not a bad
workaround though - well done!

Ronnie

Hi,

today I found another way to unfreeze the unit test runner: click the
"Show desktop" icon in the task bar (I hope it is named so in the
english windows version becaus I use the german one; it's the icon
that iconifies all windows to show the desktop). It unfreezes most of
the time....

Sincerely,
Stefan Lieser



0

Please sign in to leave a comment.