cannot change startup behavior

Using the AddIn Manager, un-checking the R# addin checkboxes does NOT result in R# not loading on the next startup. According to http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=167838&SiteID=1 this is because the addin is registered under HKLM rather than HKCU.

I had to change the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2005\LoadBehavior registry value manually (to 0? from 3). Assuming Microsoft doesn't fix this limitation, this tip might be useful in the final documentation.

(Build 215 for vs2005, by the way)

1 comment
Comment actions Permalink

Hello Kevin,

thanks a lot for your references! Actually we also faced this problem and
had no idea if it is a bug in VS or something else.
We'll consider including a mention of it into the documentation.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Using the AddIn Manager, un-checking the R# addin checkboxes does NOT
result in R# not loading on the next startup. According to
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=167838&SiteID=1
this is because the addin is registered under HKLM rather than HKCU.

I had to change the
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\8.0\AddIns\ReSharpe
rAddIn2005\LoadBehavior registry value manually (to 0? from 3).
Assuming Microsoft doesn't fix this limitation, this tip might be
useful in the final documentation.

(Build 215 for vs2005, by the way)



0

Please sign in to leave a comment.