Double Period In Auto-Completion

Build 215 for VS 2005 on Win XP.

I'm getting a double period after the member/variable when using period to
force the completion. Since I'm unable to figure out a clearer way to write
that, here's an example.

I want to get something like 'myMember.myMethod()', so I type 'myM', hit
Ctrl-Space and a selection list pops up. I cursor to the appropriate line
and hit '.' which results in 'myMember..' instead of 'myMember.'

I realize one period is not the end of the world; however, I'm a very lazy,
unproductive person and having to backspace to delete that extra period kills
me. OK, it doesn't kill me, but it's rather annoying all the same.

I don't see anything in ReSharper's options which would appear to change
this behavior. Do I need to change how I'm using this great tool, or is
this a bug? I didn't find anything on it in Tracker.


2 comments
Comment actions Permalink

http://www.intellij.net/tracker/resharper/viewSCR?publicId=16351

It's fixed in 216 (which I'm eagerly waiting for :-D).

Build 215 for VS 2005 on Win XP.

I'm getting a double period after the member/variable when using
period to force the completion. Since I'm unable to figure out a
clearer way to write that, here's an example.

I want to get something like 'myMember.myMethod()', so I type 'myM',
hit Ctrl-Space and a selection list pops up. I cursor to the
appropriate line and hit '.' which results in 'myMember..' instead of
'myMember.'

I realize one period is not the end of the world; however, I'm a very
lazy, unproductive person and having to backspace to delete that extra
period kills me. OK, it doesn't kill me, but it's rather annoying all
the same.

I don't see anything in ReSharper's options which would appear to
change this behavior. Do I need to change how I'm using this great
tool, or is this a bug? I didn't find anything on it in Tracker.



0
Comment actions Permalink

Argggh!

I dug through Tracker but didn't find that one. Thanks for the pointer.

http://www.intellij.net/tracker/resharper/viewSCR?publicId=16351

It's fixed in 216 (which I'm eagerly waiting for :-D).



0

Please sign in to leave a comment.