References to projects in solution folders

Resharper seems to lose track sometimes of identifiers in projects when
they are in "solution folders". I observed that several times now. Some
time after having moved a project into a solution folder, its
identifiers show up red. Removing the reference and adding it again
solves the problem.

6 comments
Comment actions Permalink

Just wanted to confirm that I also have some problems with solution folders.
I just split one of my libraries into few projects (for sharing purposes)
and used solution folders to organized libraries and unit tests for them.
Even though everything compiles I had to do Remove Reference / Add reference
actions few times already even though VS was restarted few times since the
change (it is third date I am working with this project structure). I am
still using FYI
Shimon.
"Andreas Hofer" <ejp10@gmx.ch> wrote in message
news:dtkps3$tav$1@is.intellij.net...

Resharper seems to lose track sometimes of identifiers in projects when
they are in "solution folders". I observed that several times now. Some
time after having moved a project into a solution folder, its
identifiers show up red. Removing the reference and adding it again
solves the problem.



0
Comment actions Permalink

Me too, using 219 on VS 2005. Many people seemed to indicate identifiers
were tracking ok, but with this message, I realize it must be related to the
solution-level folders.

"Shimon Sim" <shimonsim048@community.nospam> wrote in message
news:du284k$un6$1@is.intellij.net...

Just wanted to confirm that I also have some problems with solution
folders.
I just split one of my libraries into few projects (for sharing purposes)
and used solution folders to organized libraries and unit tests for them.
Even though everything compiles I had to do Remove Reference / Add
reference actions few times already even though VS was restarted few times
since the change (it is third date I am working with this project
structure). I am still using FYI
Shimon.
"Andreas Hofer" <ejp10@gmx.ch> wrote in message
news:dtkps3$tav$1@is.intellij.net...

>> Resharper seems to lose track sometimes of identifiers in projects when
>> they are in "solution folders". I observed that several times now. Some
>> time after having moved a project into a solution folder, its
>> identifiers show up red. Removing the reference and adding it again
>> solves the problem.
>



0
Comment actions Permalink

Could you please submit a request to the tracker if this has not be done
yet? Thanks.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Me too, using 219 on VS 2005. Many people seemed to indicate
identifiers were tracking ok, but with this message, I realize it must
be related to the solution-level folders.

"Shimon Sim" <shimonsim048@community.nospam> wrote in message
news:du284k$un6$1@is.intellij.net...

>> Just wanted to confirm that I also have some problems with solution
>> folders.
>> I just split one of my libraries into few projects (for sharing
>> purposes)
>> and used solution folders to organized libraries and unit tests for
>> them.
>> Even though everything compiles I had to do Remove Reference / Add
>> reference actions few times already even though VS was restarted few
>> times
>> since the change (it is third date I am working with this project
>> structure). I am still using FYI
>> Shimon.
>> "Andreas Hofer" <ejp10@gmx.ch> wrote in message
>> news:dtkps3$tav$1@is.intellij.net...
>>> Resharper seems to lose track sometimes of identifiers in projects
>>> when they are in "solution folders". I observed that several times
>>> now. Some time after having moved a project into a solution folder,
>>> its identifiers show up red. Removing the reference and adding it
>>> again solves the problem.
>>>


0
Comment actions Permalink

I do not have clear instructions to reproduce this problem. So I thought
I'd mention it here and observe it further. There is no point adding it
to the tracker if all you can do is closing it again because you are not
able to reproduce it. Maybe later I will be able to give an example on
how to reproduce it.

Regards,
Andreas Hofer

Dmitry Shaporenkov (JetBrains) schrieb:

Could you please submit a request to the tracker if this has not be done
yet? Thanks.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Me too, using 219 on VS 2005. Many people seemed to indicate
>> identifiers were tracking ok, but with this message, I realize it must
>> be related to the solution-level folders.
>>
>> "Shimon Sim" <shimonsim048@community.nospam> wrote in message
>> news:du284k$un6$1@is.intellij.net...
>>
>>> Just wanted to confirm that I also have some problems with solution
>>> folders.
>>> I just split one of my libraries into few projects (for sharing
>>> purposes)
>>> and used solution folders to organized libraries and unit tests for
>>> them.
>>> Even though everything compiles I had to do Remove Reference / Add
>>> reference actions few times already even though VS was restarted few
>>> times
>>> since the change (it is third date I am working with this project
>>> structure). I am still using FYI
>>> Shimon.
>>> "Andreas Hofer" <ejp10@gmx.ch> wrote in message
>>> news:dtkps3$tav$1@is.intellij.net...
>>>> Resharper seems to lose track sometimes of identifiers in projects
>>>> when they are in "solution folders". I observed that several times
>>>> now. Some time after having moved a project into a solution folder,
>>>> its identifiers show up red. Removing the reference and adding it
>>>> again solves the problem.
>>>>


0
Comment actions Permalink

Hello Andreas,

actually what we need is a brief outline of the structure of your solution.
If you post this description along with even vague description of the problem,
this would help.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I do not have clear instructions to reproduce this problem. So I
thought I'd mention it here and observe it further. There is no point
adding it to the tracker if all you can do is closing it again because
you are not able to reproduce it. Maybe later I will be able to give
an example on how to reproduce it.

Regards,
Andreas Hofer
Dmitry Shaporenkov (JetBrains) schrieb:

>> Could you please submit a request to the tracker if this has not be
>> done yet? Thanks.
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Me too, using 219 on VS 2005. Many people seemed to indicate
>>> identifiers were tracking ok, but with this message, I realize it
>>> must be related to the solution-level folders.
>>>
>>> "Shimon Sim" <shimonsim048@community.nospam> wrote in message
>>> news:du284k$un6$1@is.intellij.net...
>>>
>>>> Just wanted to confirm that I also have some problems with solution
>>>> folders.
>>>> I just split one of my libraries into few projects (for sharing
>>>> purposes)
>>>> and used solution folders to organized libraries and unit tests for
>>>> them.
>>>> Even though everything compiles I had to do Remove Reference / Add
>>>> reference actions few times already even though VS was restarted
>>>> few
>>>> times
>>>> since the change (it is third date I am working with this project
>>>> structure). I am still using FYI
>>>> Shimon.
>>>> "Andreas Hofer" <ejp10@gmx.ch> wrote in message
>>>> news:dtkps3$tav$1@is.intellij.net...
>>>>> Resharper seems to lose track sometimes of identifiers in projects
>>>>> when they are in "solution folders". I observed that several times
>>>>> now. Some time after having moved a project into a solution
>>>>> folder, its identifiers show up red. Removing the reference and
>>>>> adding it again solves the problem.
>>>>>


0
Comment actions Permalink

Ok, I posted it. Hope this helps.
http://www.intellij.net/tracker/resharper/viewSCR?publicId=18856

Regards,
Andreas Hofer

Dmitry Shaporenkov (JetBrains) schrieb:

Hello Andreas,

actually what we need is a brief outline of the structure of your
solution. If you post this description along with even vague description
of the problem, this would help.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I do not have clear instructions to reproduce this problem. So I
>> thought I'd mention it here and observe it further. There is no point
>> adding it to the tracker if all you can do is closing it again because
>> you are not able to reproduce it. Maybe later I will be able to give
>> an example on how to reproduce it.
>>
>> Regards,
>> Andreas Hofer
>> Dmitry Shaporenkov (JetBrains) schrieb:
>>
>>> Could you please submit a request to the tracker if this has not be
>>> done yet? Thanks.
>>>
>>> Regards,
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Me too, using 219 on VS 2005. Many people seemed to indicate
>>>> identifiers were tracking ok, but with this message, I realize it
>>>> must be related to the solution-level folders.
>>>>
>>>> "Shimon Sim" <shimonsim048@community.nospam> wrote in message
>>>> news:du284k$un6$1@is.intellij.net...
>>>>
>>>>> Just wanted to confirm that I also have some problems with solution
>>>>> folders.
>>>>> I just split one of my libraries into few projects (for sharing
>>>>> purposes)
>>>>> and used solution folders to organized libraries and unit tests for
>>>>> them.
>>>>> Even though everything compiles I had to do Remove Reference / Add
>>>>> reference actions few times already even though VS was restarted
>>>>> few
>>>>> times
>>>>> since the change (it is third date I am working with this project
>>>>> structure). I am still using FYI
>>>>> Shimon.
>>>>> "Andreas Hofer" <ejp10@gmx.ch> wrote in message
>>>>> news:dtkps3$tav$1@is.intellij.net...
>>>>>> Resharper seems to lose track sometimes of identifiers in projects
>>>>>> when they are in "solution folders". I observed that several times
>>>>>> now. Some time after having moved a project into a solution
>>>>>> folder, its identifiers show up red. Removing the reference and
>>>>>> adding it again solves the problem.
>>>>>>


0

Please sign in to leave a comment.