Corrupting ReSharper caches

Hi,

After this thread

http://www.intellij.net/forums/thread.jspa?threadID=206521

I tested a while to find a way to replicate some of my errors.


I have found a sequence of Actions to force the corrupting of r# caches in build 227

But it is not so easy to put it into a bug report, and you need minimum 3 different projects for testing.

but you can contact me via ICQ 1603858 or msn messanger via my forum email address.



if this is not possible pleas tell me, then i will try to create a test project, write it down a tutorial

5 comments
Comment actions Permalink

foget it, i have found an easy way make the same thing, i think this is most likeley the same bug.


- create a new dll project

- open the pregenerated Class1.cs

- replace the complete content of the file with this


- mark the block


- delete the block, now you have removed the complete System namespace form r# caches :)




Have fun :)


Carsten Jendro

null

0
Comment actions Permalink

Hi,

I reproduced this. Will try to fix shortly.
Thank you very much.

Friendly,
Dmitry

Carsten Jendro wrote:

foget it, i have found an easy way make the same thing, i think this is most likeley the same bug.


- create a new dll project

- open the pregenerated Class1.cs

- replace the complete content of the file with this

*namespace System
{
interface IFoo
{

}
}

public class Class1
{
public Class1(System.IFoo foo)
{
}
}
*

- mark the block

*namespace System
{
interface IFoo
{

}
}
*

- delete the block, now you have removed the complete System namespace form r# caches :)




Have fun :)


Carsten Jendro



--
Dmitry Lomov
Senior Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop With Pleasure!"

0
Comment actions Permalink

Hello Carsten and JetBrains Team,

After this thread

http://www.intellij.net/forums/thread.jspa?threadID=206521

I tested a while to find a way to replicate some of my errors.


I have found a sequence of Actions to force the corrupting of r# caches in build 227

But it is not so easy to put it into a bug report, and you need minimum 3 different projects for testing.

It seems that this might be related to

news://news.jetbrains.com:119/du1iub$1kf$1@is.intellij.net

especially the second problem I've described there.

Marco

0
Comment actions Permalink

can anyone post a link to the corresponding post in the forum please? i have no news access here at work.

0
Comment actions Permalink

Carsten Jendro schrieb:

can anyone post a link to the corresponding post in the forum please? i have no news access here at work.

http://www.intellij.net/forums/thread.jspa?threadID=200248&tstart=0

Marco

0

Please sign in to leave a comment.