[232] Invisible windows

Hello,

I'm currently using build 232 of R# and I've noticed a weird problem.
Pretty frequently (yet not always), when I invoke a refactoring/quickie
that brings a new window (eg. Extract Interface, or Generate Read/Write
Properties from the Alt-Ins window, ...), I see the new window flashing
open for a split second and then it's gone. VS2005 seemingly does not
respond anymore, even though it never goes into "(Not responding)" state.

At first I thought this was some kind of threading deadlock, but after a
while I discovered VS didn't lock at all, it's just waiting for my input
in a modal yet invisible window. For example, I can press Escape to
return to the previous state, or Return to apply the default settings.
Also, when I type, I can sometimes see a tooltip or something similar
showing what I'm typing.

It's not THAT much of a problem (because I know most of the sequences by
heart, and even if I don't, I can kill VS and it will recover right till
the moment before the dialog popped up) but it's a bit annoying none the
less.

Apart from that, BIG kudos on your builds since 230. I have noticed
immense speed improvements (at least, while coding -- I don't usually
monitor startup times and don't want to contradict other people's
messages in this newsgroup).

Small thing, the bitmap displayed during installation (the big R# on the
left) looks a bit flakey, I can see red artefacts all over the place :)

Thanks for such a nice product!
Filip.

2 comments
Comment actions Permalink

I had that problem when I first installed 232. Turns out the window is still
there, but it's BEHIND the VS window.

To fix it, try "restoring" your Visual Studio window before you do such an
operation (i.e. double click on the title bar, so that the Visual Studio
window is no longer maximised). Then, resize the VS window so that you can
see your desktop on the left-hand half of the screen. Then bring up the R#
window, and you'll see it in the top-left corner of your screen. You can
then click on it and interact as normal.

Seemingly after you've done this once, you can then maximise VS again and
all will be well (was for me anyway :-D).

hth -
/gerrod

Hello,

I'm currently using build 232 of R# and I've noticed a weird problem.
Pretty frequently (yet not always), when I invoke a
refactoring/quickie that brings a new window (eg. Extract Interface,
or Generate Read/Write Properties from the Alt-Ins window, ...), I see
the new window flashing open for a split second and then it's gone.
VS2005 seemingly does not respond anymore, even though it never goes
into "(Not responding)" state.

At first I thought this was some kind of threading deadlock, but after
a while I discovered VS didn't lock at all, it's just waiting for my
input in a modal yet invisible window. For example, I can press Escape
to return to the previous state, or Return to apply the default
settings. Also, when I type, I can sometimes see a tooltip or
something similar showing what I'm typing.

It's not THAT much of a problem (because I know most of the sequences
by heart, and even if I don't, I can kill VS and it will recover right
till the moment before the dialog popped up) but it's a bit annoying
none the less.

Apart from that, BIG kudos on your builds since 230. I have noticed
immense speed improvements (at least, while coding -- I don't usually
monitor startup times and don't want to contradict other people's
messages in this newsgroup).

Small thing, the bitmap displayed during installation (the big R# on
the left) looks a bit flakey, I can see red artefacts all over the
place :)

Thanks for such a nice product!
Filip.



0
Comment actions Permalink

We've discovered this problem half an hour after we published the build. We
were going to publish the fix ASAP, but we did not for some reasons and
probably will do today. Thank You for Your patience.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.