Build #240 does not get removed when turned off in Tools | Add-Ins

I'm toggling Resharper off/on as I need it due to the problems with
SmartBackspace. I have now discovered that when I turn Resharper off it
continues to attempt to build the cache in the background - is this a
VS2005 problem or a R# one?

6 comments
Comment actions Permalink

Hello Mike,

do you mean that you see ReSharper background activity progress indicator
after disabling ReSharper?
This, of course, should not happen.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm toggling Resharper off/on as I need it due to the problems with
SmartBackspace. I have now discovered that when I turn Resharper off
it continues to attempt to build the cache in the background - is this
a VS2005 problem or a R# one?



0
Comment actions Permalink

Dmitry,

I unchecked Resharper (both check boxes) but when I go back into the
Add-In manager is is still showing as checked in both boxes. I only
discovered this because VS2005 hung on me after I had unchecked the
Resharper options and the CLR debugger still showed Resharper code as
being active.

I uninstalled #240 as a means of getting rid of it because of my
problems with SmartBackspace.


In article <c8a894d916c9d18c83dc26f5cd313@news.intellij.net>,
dsha@jetbrains.com says...

Hello Mike,

do you mean that you see ReSharper background activity progress indicator
after disabling ReSharper?
This, of course, should not happen.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm toggling Resharper off/on as I need it due to the problems with
SmartBackspace. I have now discovered that when I turn Resharper off
it continues to attempt to build the cache in the background - is this
a VS2005 problem or a R# one?


0
Comment actions Permalink

Hello Mike,

so do you mean that you can't disable ReSharper in the add-in manager? Is
this problem repeatable?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Dmitry,

I unchecked Resharper (both check boxes) but when I go back into the
Add-In manager is is still showing as checked in both boxes. I only
discovered this because VS2005 hung on me after I had unchecked the
Resharper options and the CLR debugger still showed Resharper code as
being active.

I uninstalled #240 as a means of getting rid of it because of my
problems with SmartBackspace.

In article <c8a894d916c9d18c83dc26f5cd313@news.intellij.net>,
dsha@jetbrains.com says...

>> Hello Mike,
>>
>> do you mean that you see ReSharper background activity progress
>> indicator
>> after disabling ReSharper?
>> This, of course, should not happen.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I'm toggling Resharper off/on as I need it due to the problems with
>>> SmartBackspace. I have now discovered that when I turn Resharper off
>>> it continues to attempt to build the cache in the background - is
>>> this a VS2005 problem or a R# one?
>>>


0
Comment actions Permalink

In article <c8a894d916cc408c83dd684ff40e3@news.intellij.net>,
Dmitry,

Yes, it was repeatable. Also, it was not possible to uncheck the "load
at startup" option either. Both check boxes would clear, but when the
dialog was closed and re-opened they were both checked again. This is
why I uninstalled Resharper.

The porblem may well be linked to the out-of-memory exception/Smart
Backspace proble I reported in another thread so I will re-install and
see if I can disable/enable Resharper in the add-in manager without
loading my large solution (perhaps a new solution) and I will revert
with my findings.

Mike

dsha@jetbrains.com says...

Hello Mike,

so do you mean that you can't disable ReSharper in the add-in manager? Is
this problem repeatable?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Dmitry,

I unchecked Resharper (both check boxes) but when I go back into the
Add-In manager is is still showing as checked in both boxes. I only
discovered this because VS2005 hung on me after I had unchecked the
Resharper options and the CLR debugger still showed Resharper code as
being active.

I uninstalled #240 as a means of getting rid of it because of my
problems with SmartBackspace.

In article <c8a894d916c9d18c83dc26f5cd313@news.intellij.net>,
dsha@jetbrains.com says...

>> Hello Mike,
>>
>> do you mean that you see ReSharper background activity progress
>> indicator
>> after disabling ReSharper?
>> This, of course, should not happen.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I'm toggling Resharper off/on as I need it due to the problems with
>>> SmartBackspace. I have now discovered that when I turn Resharper off
>>> it continues to attempt to build the cache in the background - is
>>> this a VS2005 problem or a R# one?
>>>


0
Comment actions Permalink

Dmitry,

I carried out the following test:

1. install Resharper Build #240
2. open VS2005, do not open ant existing projects or solutions
3. disable Resharper in Add-In Manager, status bar messages displayed
tracking the disable process
4. open Add-In Manager, Resharper shows as disable and the Resharper
menu is grayed out
5. disable load of Resharper at start up
6. close VS2005
7. open VS2005
8. Resharper shows as enabled and "load at startup" set as well

There is definitely something wrong here.....

Mike

In article <MPG.1ec507223759fbce989689@news.intellij.net>,
gravity@romplaza.demon.co.uk says...

In article <c8a894d916cc408c83dd684ff40e3@news.intellij.net>,
Dmitry,

Yes, it was repeatable. Also, it was not possible to uncheck the "load
at startup" option either. Both check boxes would clear, but when the
dialog was closed and re-opened they were both checked again. This is
why I uninstalled Resharper.

The porblem may well be linked to the out-of-memory exception/Smart
Backspace proble I reported in another thread so I will re-install and
see if I can disable/enable Resharper in the add-in manager without
loading my large solution (perhaps a new solution) and I will revert
with my findings.

Mike

dsha@jetbrains.com says...

Hello Mike,

so do you mean that you can't disable ReSharper in the add-in manager? Is
this problem repeatable?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Dmitry,

I unchecked Resharper (both check boxes) but when I go back into the
Add-In manager is is still showing as checked in both boxes. I only
discovered this because VS2005 hung on me after I had unchecked the
Resharper options and the CLR debugger still showed Resharper code as
being active.

I uninstalled #240 as a means of getting rid of it because of my
problems with SmartBackspace.

In article <c8a894d916c9d18c83dc26f5cd313@news.intellij.net>,
dsha@jetbrains.com says...

>> Hello Mike,
>>
>> do you mean that you see ReSharper background activity progress
>> indicator
>> after disabling ReSharper?
>> This, of course, should not happen.
>> Regards,

0
Comment actions Permalink

Hello Mike,

thanks for your test, I see the problem now. Actually the issue is that the
'startup' checkbox
isn't persisted across VS sessions. Details can be found at:
http://lab.msdn.microsoft.com/ProductFeedback/viewFeedback.aspx?FeedbackId=75f40e0b-af8f-4999-befb-b8ca5d85d444
Actually there is a continuation of that discussion somewhere in Microsoft
forums, but I can't find it right now.
You can also try http://blogs.msdn.com/saraford/archive/2006/01/24/517044.aspx



Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Dmitry,

I carried out the following test:

1. install Resharper Build #240
2. open VS2005, do not open ant existing projects or solutions
3. disable Resharper in Add-In Manager, status bar messages displayed
tracking the disable process
4. open Add-In Manager, Resharper shows as disable and the Resharper
menu is grayed out
5. disable load of Resharper at start up
6. close VS2005
7. open VS2005
8. Resharper shows as enabled and "load at startup" set as well
There is definitely something wrong here.....

Mike

In article <MPG.1ec507223759fbce989689@news.intellij.net>,
gravity@romplaza.demon.co.uk says...

>> In article <c8a894d916cc408c83dd684ff40e3@news.intellij.net>, Dmitry,
>>
>> Yes, it was repeatable. Also, it was not possible to uncheck the
>> "load at startup" option either. Both check boxes would clear, but
>> when the dialog was closed and re-opened they were both checked
>> again. This is why I uninstalled Resharper.
>>
>> The porblem may well be linked to the out-of-memory exception/Smart
>> Backspace proble I reported in another thread so I will re-install
>> and see if I can disable/enable Resharper in the add-in manager
>> without loading my large solution (perhaps a new solution) and I will
>> revert with my findings.
>>
>> Mike
>>
>> dsha@jetbrains.com says...
>>
>>> Hello Mike,
>>>
>>> so do you mean that you can't disable ReSharper in the add-in
>>> manager? Is this problem repeatable?
>>>
>>> Regards,
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Dmitry,
>>>>
>>>> I unchecked Resharper (both check boxes) but when I go back into
>>>> the Add-In manager is is still showing as checked in both boxes. I
>>>> only discovered this because VS2005 hung on me after I had
>>>> unchecked the Resharper options and the CLR debugger still showed
>>>> Resharper code as being active.
>>>>
>>>> I uninstalled #240 as a means of getting rid of it because of my
>>>> problems with SmartBackspace.
>>>>
>>>> In article <c8a894d916c9d18c83dc26f5cd313@news.intellij.net>,
>>>> dsha@jetbrains.com says...
>>>>
>>>>> Hello Mike,
>>>>>
>>>>> do you mean that you see ReSharper background activity progress
>>>>> indicator
>>>>> after disabling ReSharper?
>>>>> This, of course, should not happen.
>>>>> Regards,


0

Please sign in to leave a comment.