no more intellisense support after unintalling ReSharper 2.0 beta

Yesterday I uninstalled ReSharper 2.0 beta and after that, every time I
tried to get intellisense by pressing CTRL-SHIFT I got a mesagebox from
Visual Studio 2005 saying: "The Add-in supporting this command could not be
loaded. Do you wish to remove the command? If you choose yes, you can
re-create the command by reinstalling the Add-in.". When I pressed yes the
message box didn't show up anymore. Great? No! All intellisense is now
completely gone.

Can anyone help me and tell how to restore the initial Visual Studio
intellisense settings? Live without intellisense is hell ;)



Steven


5 comments
Comment actions Permalink

Hello Steven,

to restore VS IntelliSense on Ctrl+Space, you need to restore the association
between the 'Edit.CompleteWord'
command and Ctrl+Space shortcut. To do that, go to the Tools|Options|Environment|Keyboard
and bind 'Edit.CompleteWord'
to the Ctrl-Space (or whatever key combination you like). You can also reset
the keyboard mapping scheme to the default
in the same dialog.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Yesterday I uninstalled ReSharper 2.0 beta and after that, every time
I tried to get intellisense by pressing CTRL-SHIFT I got a mesagebox
from Visual Studio 2005 saying: "The Add-in supporting this command
could not be loaded. Do you wish to remove the command? If you choose
yes, you can re-create the command by reinstalling the Add-in.". When
I pressed yes the message box didn't show up anymore. Great? No! All
intellisense is now completely gone.

Can anyone help me and tell how to restore the initial Visual Studio
intellisense settings? Live without intellisense is hell ;)

Steven



0
Comment actions Permalink

Hi Dmitry,

thanks, Ctrl-Space works again, but I still haven't got my completion list
back that I'm used to get after each typed character. Even though
"Tools|Options|Text Editor|C#|IntelliSense|Completion List|Show completion
list after a character is typed" is checked.

How can I fix this?

Steven



"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schreef in bericht
news:c8a894d917056a8c83fca9370d69f@news.intellij.net...

Hello Steven,

>

to restore VS IntelliSense on Ctrl+Space, you need to restore the

association

between the 'Edit.CompleteWord'
command and Ctrl+Space shortcut. To do that, go to the

Tools|Options|Environment|Keyboard

and bind 'Edit.CompleteWord'
to the Ctrl-Space (or whatever key combination you like). You can also

reset

the keyboard mapping scheme to the default
in the same dialog.

>
>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>

Yesterday I uninstalled ReSharper 2.0 beta and after that, every time
I tried to get intellisense by pressing CTRL-SHIFT I got a mesagebox
from Visual Studio 2005 saying: "The Add-in supporting this command
could not be loaded. Do you wish to remove the command? If you choose
yes, you can re-create the command by reinstalling the Add-in.". When
I pressed yes the message box didn't show up anymore. Great? No! All
intellisense is now completely gone.

>

Can anyone help me and tell how to restore the initial Visual Studio
intellisense settings? Live without intellisense is hell ;)

>

Steven

>

>
>


0
Comment actions Permalink

Hello Steven,

that's odd, I have no idea why it doesn't work if the mentioned option is
enabled. Does it happen
in all files / solutions?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Dmitry,

thanks, Ctrl-Space works again, but I still haven't got my completion
list back that I'm used to get after each typed character. Even though
"Tools|Options|Text Editor|C#|IntelliSense|Completion List|Show
completion list after a character is typed" is checked.

How can I fix this?

Steven

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schreef in
bericht news:c8a894d917056a8c83fca9370d69f@news.intellij.net...

>> Hello Steven,
>>
>> to restore VS IntelliSense on Ctrl+Space, you need to restore the
>>

association

>> between the 'Edit.CompleteWord'
>> command and Ctrl+Space shortcut. To do that, go to the

Tools|Options|Environment|Keyboard

>> and bind 'Edit.CompleteWord'
>> to the Ctrl-Space (or whatever key combination you like). You can
>> also

reset

>> the keyboard mapping scheme to the default
>> in the same dialog.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Yesterday I uninstalled ReSharper 2.0 beta and after that, every
>>> time I tried to get intellisense by pressing CTRL-SHIFT I got a
>>> mesagebox from Visual Studio 2005 saying: "The Add-in supporting
>>> this command could not be loaded. Do you wish to remove the command?
>>> If you choose yes, you can re-create the command by reinstalling the
>>> Add-in.". When I pressed yes the message box didn't show up anymore.
>>> Great? No! All intellisense is now completely gone.
>>>
>>> Can anyone help me and tell how to restore the initial Visual Studio
>>> intellisense settings? Live without intellisense is hell ;)
>>>
>>> Steven
>>>


0
Comment actions Permalink

It happens in all my solutions, but only in C# files (including code
behind). IntelliSense on .aspx works fine.

Steven


"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schreef in bericht
news:c8a894d91709348c83febb2019c37@news.intellij.net...

Hello Steven,

>

that's odd, I have no idea why it doesn't work if the mentioned option is
enabled. Does it happen
in all files / solutions?

>
>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>

Hi Dmitry,

>

thanks, Ctrl-Space works again, but I still haven't got my completion
list back that I'm used to get after each typed character. Even though
"Tools|Options|Text Editor|C#|IntelliSense|Completion List|Show
completion list after a character is typed" is checked.

>

How can I fix this?

>

Steven

>

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schreef in
bericht news:c8a894d917056a8c83fca9370d69f@news.intellij.net...

>
>> Hello Steven,
>>
>> to restore VS IntelliSense on Ctrl+Space, you need to restore the
>>

association

>
>> between the 'Edit.CompleteWord'
>> command and Ctrl+Space shortcut. To do that, go to the

Tools|Options|Environment|Keyboard

>
>> and bind 'Edit.CompleteWord'
>> to the Ctrl-Space (or whatever key combination you like). You can
>> also

reset

>
>> the keyboard mapping scheme to the default
>> in the same dialog.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Yesterday I uninstalled ReSharper 2.0 beta and after that, every
>>> time I tried to get intellisense by pressing CTRL-SHIFT I got a
>>> mesagebox from Visual Studio 2005 saying: "The Add-in supporting
>>> this command could not be loaded. Do you wish to remove the command?
>>> If you choose yes, you can re-create the command by reinstalling the
>>> Add-in.". When I pressed yes the message box didn't show up anymore.
>>> Great? No! All intellisense is now completely gone.
>>>
>>> Can anyone help me and tell how to restore the initial Visual Studio
>>> intellisense settings? Live without intellisense is hell ;)
>>>
>>> Steven
>>>

>
>


0
Comment actions Permalink

Hello Steven,

You should also check the "Auto list members" checkbox on the Tools ->
Options -> Text Editor -> C# -> General page.

Oleg Stepanov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

It happens in all my solutions, but only in C# files (including code
behind). IntelliSense on .aspx works fine.

Steven

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schreef in
bericht news:c8a894d91709348c83febb2019c37@news.intellij.net...

>> Hello Steven,
>>
>> that's odd, I have no idea why it doesn't work if the mentioned
>> option is
>> enabled. Does it happen
>> in all files / solutions?
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hi Dmitry,
>>>
>>> thanks, Ctrl-Space works again, but I still haven't got my
>>> completion list back that I'm used to get after each typed
>>> character. Even though "Tools|Options|Text
>>> Editor|C#|IntelliSense|Completion List|Show completion list after a
>>> character is typed" is checked.
>>>
>>> How can I fix this?
>>>
>>> Steven
>>>
>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schreef in
>>> bericht news:c8a894d917056a8c83fca9370d69f@news.intellij.net...
>>>
>>>> Hello Steven,
>>>>
>>>> to restore VS IntelliSense on Ctrl+Space, you need to restore the
>>>>
>>> association
>>>
>>>> between the 'Edit.CompleteWord'
>>>> command and Ctrl+Space shortcut. To do that, go to the
>>> Tools|Options|Environment|Keyboard
>>>
>>>> and bind 'Edit.CompleteWord'
>>>> to the Ctrl-Space (or whatever key combination you like). You can
>>>> also
>>> reset
>>>
>>>> the keyboard mapping scheme to the default
>>>> in the same dialog.
>>>> Regards,
>>>> Dmitry Shaporenkov
>>>> JetBrains, Inc
>>>> http://www.jetbrains.com
>>>> "Develop with pleasure!"
>>>>> Yesterday I uninstalled ReSharper 2.0 beta and after that, every
>>>>> time I tried to get intellisense by pressing CTRL-SHIFT I got a
>>>>> mesagebox from Visual Studio 2005 saying: "The Add-in supporting
>>>>> this command could not be loaded. Do you wish to remove the
>>>>> command? If you choose yes, you can re-create the command by
>>>>> reinstalling the Add-in.". When I pressed yes the message box
>>>>> didn't show up anymore. Great? No! All intellisense is now
>>>>> completely gone.
>>>>>
>>>>> Can anyone help me and tell how to restore the initial Visual
>>>>> Studio intellisense settings? Live without intellisense is hell
>>>>> ;)
>>>>>
>>>>> Steven
>>>>>


0

Please sign in to leave a comment.