[237] VS2003 UNDO does not work

Whenever I wish to undo the last change with recently installed update I get
th emessage Microsoft Development Environment, Unknown undo/redo error.
.
Any ideas as to the causes? It worked fine with build 165.




8 comments
Comment actions Permalink

Hello rolf_eleveld,

does restart of VS help?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Whenever I wish to undo the last change with recently installed update
I get
th emessage Microsoft Development Environment, Unknown undo/redo
error.
.
Any ideas as to the causes? It worked fine with build 165.



0
Comment actions Permalink

Yes that helped.
Thank you very much for the swift reply as it took me more time to restart
the entire solution...

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d91617918c83764e91325ce@news.intellij.net...

Hello rolf_eleveld,

>

does restart of VS help?

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Whenever I wish to undo the last change with recently installed update
>> I get
>> th emessage Microsoft Development Environment, Unknown undo/redo
>> error.
>> .
>> Any ideas as to the causes? It worked fine with build 165.
>



0
Comment actions Permalink

Hello rolf_eleveld,

if you notice some pattern leading to this problem, please post it. We've
been
looking into it for a long time already, but still don't know a reliable
repro.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Yes that helped.
Thank you very much for the swift reply as it took me more time to
restart
the entire solution...
"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d91617918c83764e91325ce@news.intellij.net...

>> Hello rolf_eleveld,
>>
>> does restart of VS help?
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Whenever I wish to undo the last change with recently installed
>>> update
>>> I get
>>> th emessage Microsoft Development Environment, Unknown undo/redo
>>> error.
>>> .
>>> Any ideas as to the causes? It worked fine with build 165.


0
Comment actions Permalink

I do have 2 more VPC's on whic I develop. I will give one of them an update of Resharper 2.0 this friday and take step-by-step notes. I will post on this thread with the results.

0
Comment actions Permalink

Hello Dmitry,

I run into this problem daily in VS2005. However, for me it seems to be
somehow related to Resharper Intellisense. I have been using the EAP builds
of R# 2.0 from the beginning. For the longest time, I used VS Intellisense
because the R# Intellisense was just too buggy for me. During that time,
I never encountered the undo problem. Then, a couple builds ago, I decided
to try out R# Intellisense to see if it had stabelized. I turned on "auto-popup
when character is typed" and it seemed to work great for me for an hour or
so, but then it stopped working, and at the same time the undo broke as well.
When I restarted VS, everything worked again...but then again after an hour
or so of use, both the R# Intellisense and the Undo broke again. If I use
the VS Intellisense, the undo never breaks.

I am still trying to figure out if there's a particular thing I am doing
that causes these things to break. I will let you know if I am able to figure
that out. However, I thought it was worth sharing that at least for me,
the undo problem seems to be related to R# Intellisense.

Hope this helps.

~Andy Alm

Hello rolf_eleveld,

if you notice some pattern leading to this problem, please post it.
We've
been
looking into it for a long time already, but still don't know a
reliable
repro.
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Yes that helped.
>> Thank you very much for the swift reply as it took me more time to
>> restart
>> the entire solution...
>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in
>> message
>> news:c8a894d91617918c83764e91325ce@news.intellij.net...
>>> Hello rolf_eleveld,
>>>
>>> does restart of VS help?
>>>
>>> Regards,
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Whenever I wish to undo the last change with recently installed
>>>> update
>>>> I get
>>>> th emessage Microsoft Development Environment, Unknown undo/redo
>>>> error.
>>>> .
>>>> Any ideas as to the causes? It worked fine with build 165.


0
Comment actions Permalink

Hello Andy,

thanks for this information! We'll try to investigate if there is any link
between ReSharper's IntelliSense
and undo corruption.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Dmitry,

I run into this problem daily in VS2005. However, for me it seems to
be
somehow related to Resharper Intellisense. I have been using the EAP
builds
of R# 2.0 from the beginning. For the longest time, I used VS
Intellisense
because the R# Intellisense was just too buggy for me. During that
time,
I never encountered the undo problem. Then, a couple builds ago, I
decided
to try out R# Intellisense to see if it had stabelized. I turned on
"auto-popup
when character is typed" and it seemed to work great for me for an
hour or
so, but then it stopped working, and at the same time the undo broke
as well.
When I restarted VS, everything worked again...but then again after
an hour
or so of use, both the R# Intellisense and the Undo broke again. If I
use
the VS Intellisense, the undo never breaks.

I am still trying to figure out if there's a particular thing I am
doing that causes these things to break. I will let you know if I am
able to figure that out. However, I thought it was worth sharing that
at least for me, the undo problem seems to be related to R#
Intellisense.

Hope this helps.

~Andy Alm

>> Hello rolf_eleveld,
>>
>> if you notice some pattern leading to this problem, please post it.
>> We've
>> been
>> looking into it for a long time already, but still don't know a
>> reliable
>> repro.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Yes that helped.
>>> Thank you very much for the swift reply as it took me more time to
>>> restart
>>> the entire solution...
>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in
>>> message
>>> news:c8a894d91617918c83764e91325ce@news.intellij.net...
>>>> Hello rolf_eleveld,
>>>>
>>>> does restart of VS help?
>>>>
>>>> Regards,
>>>> Dmitry Shaporenkov
>>>> JetBrains, Inc
>>>> http://www.jetbrains.com
>>>> "Develop with pleasure!"
>>>>> Whenever I wish to undo the last change with recently installed
>>>>> update
>>>>> I get
>>>>> th emessage Microsoft Development Environment, Unknown undo/redo
>>>>> error.
>>>>> .
>>>>> Any ideas as to the causes? It worked fine with build 165.


0
Comment actions Permalink

Well after updating all my machines this weekend I did not experience it with the latest builds . I do not have a clean copy of the original machine so I cannot reproduce the error.

0
Comment actions Permalink

Hello Rolf,

ok, let's hope the problem went away or wait until someone finds a way to
reproduce it. Thanks.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Well after updating all my machines this weekend I did not experience
it with the latest builds . I do not have a clean copy of the
original machine so I cannot reproduce the error.



0

Please sign in to leave a comment.