Disable ReSharper Load at Startup

Why can I prevent ReSharper from loading at startup?
If I uncheck the startup checkbox, it still loads next time I restart Visual
Studio.
This used to work on version 1


8 comments
Comment actions Permalink

Hello Jeff,

Do you use Visual Studio 2003?

Why can I prevent ReSharper from loading at startup?
If I uncheck the startup checkbox, it still loads next time I restart
Visual
Studio.
This used to work on version 1

Thanks,
Andrey Simanovsky


0
Comment actions Permalink

.... and if you're using VS 2005, this is a known bug in it. You can still
disable ReSharper on startup via registry value:
HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2005\LoadBehavior

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Jeff,

Do you use Visual Studio 2003?

>> Why can I prevent ReSharper from loading at startup?
>> If I uncheck the startup checkbox, it still loads next time I restart
>> Visual
>> Studio.
>> This used to work on version 1

Thanks,
Andrey Simanovsky




0
Comment actions Permalink

I am using VS2005.
Is this a known but in VisualStudio or ReSharper?
Thanks,
Jeff

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d919fcf28c869bf77c6c833@news.intellij.net...

... and if you're using VS 2005, this is a known bug in it. You can still
disable ReSharper on startup via registry value:
HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2005\LoadBehavior

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Hello Jeff,
>>
>> Do you use Visual Studio 2003?
>>
>>> Why can I prevent ReSharper from loading at startup?
>>> If I uncheck the startup checkbox, it still loads next time I restart
>>> Visual
>>> Studio.
>>> This used to work on version 1
>> Thanks,
>> Andrey Simanovsky
>
>



0
Comment actions Permalink

I set LoadBehavior to 2 which does the trick.

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d919fcf28c869bf77c6c833@news.intellij.net...

... and if you're using VS 2005, this is a known bug in it. You can still
disable ReSharper on startup via registry value:
HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2005\LoadBehavior

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Hello Jeff,
>>
>> Do you use Visual Studio 2003?
>>
>>> Why can I prevent ReSharper from loading at startup?
>>> If I uncheck the startup checkbox, it still loads next time I restart
>>> Visual
>>> Studio.
>>> This used to work on version 1
>> Thanks,
>> Andrey Simanovsky
>
>



0
Comment actions Permalink

Hello Jeff,

better set it to zero, sorry, I've not mentioned that.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I set LoadBehavior to 2 which does the trick.

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d919fcf28c869bf77c6c833@news.intellij.net...

>> ... and if you're using VS 2005, this is a known bug in it. You can
>> still disable ReSharper on startup via registry value:
>> HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2
>> 005\LoadBehavior
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hello Jeff,
>>>
>>> Do you use Visual Studio 2003?
>>>
>>>> Why can I prevent ReSharper from loading at startup?
>>>> If I uncheck the startup checkbox, it still loads next time I
>>>> restart
>>>> Visual
>>>> Studio.
>>>> This used to work on version 1
>>> Thanks,
>>> Andrey Simanovsky


0
Comment actions Permalink

Hello Jeff,

this is a VS 2005 bug. You can learn more about this issue by searching at
microsoft forums (unfortunately
I have no the direct link at hands right now).


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I am using VS2005.
Is this a known but in VisualStudio or ReSharper?
Thanks,
Jeff
"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d919fcf28c869bf77c6c833@news.intellij.net...

>> ... and if you're using VS 2005, this is a known bug in it. You can
>> still disable ReSharper on startup via registry value:
>> HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2
>> 005\LoadBehavior
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hello Jeff,
>>>
>>> Do you use Visual Studio 2003?
>>>
>>>> Why can I prevent ReSharper from loading at startup?
>>>> If I uncheck the startup checkbox, it still loads next time I
>>>> restart
>>>> Visual
>>>> Studio.
>>>> This used to work on version 1
>>> Thanks,
>>> Andrey Simanovsky


0
Comment actions Permalink

When disabling ReSharper by editing the registry, it does not load at
startup but will still try to load if you issue certain commands such as
ctrl-N or ctrl-space.
How can I prevent this delayed loading?

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d919fcf28c869bf77c6c833@news.intellij.net...

... and if you're using VS 2005, this is a known bug in it. You can still
disable ReSharper on startup via registry value:
HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2005\LoadBehavior

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Hello Jeff,
>>
>> Do you use Visual Studio 2003?
>>
>>> Why can I prevent ReSharper from loading at startup?
>>> If I uncheck the startup checkbox, it still loads next time I restart
>>> Visual
>>> Studio.
>>> This used to work on version 1
>> Thanks,
>> Andrey Simanovsky
>
>



0
Comment actions Permalink

Hello Jeff,

unfortunately there is no way to do that. When you press a shortcut assigned
to a ReSharper command,
VS has no other choice than to load ReSharper and let it hangle the command.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When disabling ReSharper by editing the registry, it does not load at
startup but will still try to load if you issue certain commands such
as
ctrl-N or ctrl-space.
How can I prevent this delayed loading?
"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d919fcf28c869bf77c6c833@news.intellij.net...

>> ... and if you're using VS 2005, this is a known bug in it. You can
>> still disable ReSharper on startup via registry value:
>> HKLM(HKCU)\Software\Microsoft\VisualStudio\8.0\AddIns\ReSharperAddIn2
>> 005\LoadBehavior
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hello Jeff,
>>>
>>> Do you use Visual Studio 2003?
>>>
>>>> Why can I prevent ReSharper from loading at startup?
>>>> If I uncheck the startup checkbox, it still loads next time I
>>>> restart
>>>> Visual
>>>> Studio.
>>>> This used to work on version 1
>>> Thanks,
>>> Andrey Simanovsky


0

Please sign in to leave a comment.