[301] Slow typing again

Slow typing is back. I had to turn off 'track changes' in to correct
this, but in , its back.

If I turn off the navigation bar, my problem with slow response to typing
goes away.

This doesn't seem right that I would have to disable features of the IDE so
that R# doesn't interfere with non-refactoring functionality.

Is it possible that R# is trying to do too much for us at the expense of us
having to do too much for it?


5 comments
Comment actions Permalink

Also, why would the Navigation Bar interfere with typing?


0
Comment actions Permalink

If I turn off the navigation bar, my problem with slow response to
typing goes away.


ReSharper doesn't do anything with the navigation bar so it's more likely
that the slow down is inside VisualStudio's code, not ReSharper's. Have you
tried disabling ReSharper (with navigation bar enabled)?

Valentin Kipiatkov
CTO and Chief Scientist
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Slow typing is back. I had to turn off 'track changes' in to
correct this, but in , its back.

If I turn off the navigation bar, my problem with slow response to
typing goes away.

This doesn't seem right that I would have to disable features of the
IDE so that R# doesn't interfere with non-refactoring functionality.

Is it possible that R# is trying to do too much for us at the expense
of us having to do too much for it?



0
Comment actions Permalink

If by disabling, you mean uncheck it in the Add-In manager, then the
navigation bar still slows typing. Well, you can't always get want you
want...
"Valentin Kipiatkov (JetBrains)" <valentin@jetbrains.com> wrote in message
news:46346ef1ec4c68c8d8a6cd0e2797@news.intellij.net...
>> If I turn off the navigation bar, my problem with slow response to
>> typing goes away.
>

ReSharper doesn't do anything with the navigation bar so it's more likely
that the slow down is inside VisualStudio's code, not ReSharper's. Have
you tried disabling ReSharper (with navigation bar enabled)?

>

Valentin Kipiatkov
CTO and Chief Scientist
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Slow typing is back. I had to turn off 'track changes' in to
>> correct this, but in , its back.
>>
>> If I turn off the navigation bar, my problem with slow response to
>> typing goes away.
>>
>> This doesn't seem right that I would have to disable features of the
>> IDE so that R# doesn't interfere with non-refactoring functionality.
>>
>> Is it possible that R# is trying to do too much for us at the expense
>> of us having to do too much for it?
>>
>



0
Comment actions Permalink

Hello Richard,

so it doesn't look like a ReSharper problem, if disabling ReSharper doesn't
get rid of it...

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

If by disabling, you mean uncheck it in the Add-In manager, then the
navigation bar still slows typing. Well, you can't always get want
you
want...
"Valentin Kipiatkov (JetBrains)" <valentin@jetbrains.com> wrote in
message
news:46346ef1ec4c68c8d8a6cd0e2797@news.intellij.net...

>>> If I turn off the navigation bar, my problem with slow response to
>>> typing goes away.
>>>
>> ReSharper doesn't do anything with the navigation bar so it's more
>> likely that the slow down is inside VisualStudio's code, not
>> ReSharper's. Have you tried disabling ReSharper (with navigation bar
>> enabled)?
>>
>> Valentin Kipiatkov
>> CTO and Chief Scientist
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Slow typing is back. I had to turn off 'track changes' in to
>>> correct this, but in , its back.
>>>
>>> If I turn off the navigation bar, my problem with slow response to
>>> typing goes away.
>>>
>>> This doesn't seem right that I would have to disable features of the
>>> IDE so that R# doesn't interfere with non-refactoring functionality.
>>>
>>> Is it possible that R# is trying to do too much for us at the
>>> expense of us having to do too much for it?
>>>


0
Comment actions Permalink

I reverted to build 300 to see if other odd behavior was being caused by
301, such as undocked VS 2005 windows moving around against my wishes (it
seems to have been), and the slow typing with the VS navigator bar no longer
is an issue.

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d91b75428c8d91673c8337b@news.intellij.net...

Hello Richard,

>

so it doesn't look like a ReSharper problem, if disabling ReSharper
doesn't get rid of it...

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> If by disabling, you mean uncheck it in the Add-In manager, then the
>> navigation bar still slows typing. Well, you can't always get want
>> you
>> want...
>> "Valentin Kipiatkov (JetBrains)" <valentin@jetbrains.com> wrote in
>> message
>> news:46346ef1ec4c68c8d8a6cd0e2797@news.intellij.net...
>>>> If I turn off the navigation bar, my problem with slow response to
>>>> typing goes away.
>>>>
>>> ReSharper doesn't do anything with the navigation bar so it's more
>>> likely that the slow down is inside VisualStudio's code, not
>>> ReSharper's. Have you tried disabling ReSharper (with navigation bar
>>> enabled)?
>>>
>>> Valentin Kipiatkov
>>> CTO and Chief Scientist
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Slow typing is back. I had to turn off 'track changes' in to
>>>> correct this, but in , its back.
>>>>
>>>> If I turn off the navigation bar, my problem with slow response to
>>>> typing goes away.
>>>>
>>>> This doesn't seem right that I would have to disable features of the
>>>> IDE so that R# doesn't interfere with non-refactoring functionality.
>>>>
>>>> Is it possible that R# is trying to do too much for us at the
>>>> expense of us having to do too much for it?
>>>>
>



0

Please sign in to leave a comment.