[452] Completion Behavior after a dot seems to be ignored

I just installed 452 and found the only Completion Behavior item checked
by default was "A letter or a digit". This behavior worked as expected. Now
that I've also check "A dot and other member selectors" and "A new ...",
Resharper does not show the completion list after the dot but does after
new. Is this a known issue?


7 comments
Comment actions Permalink

I just installed 452 and found the only Completion Behavior item
checked by default was "A letter or a digit". This behavior worked as
expected. Now that I've also check "A dot and other member selectors"
and "A new ...", Resharper does not show the completion list after the
dot but does after new. Is this a known issue?


Is this a known issue? I really want my completion lists back.


0
Comment actions Permalink

I can't wait to get my hands on R# 3.0, but I just rolled back to build 370.
I need my auto-completion after a dot.


0
Comment actions Permalink

Hello,

Yes, it's a know bug with persisting completion options which is fixed
in recent builds.

Oleg Stepanov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I just installed 452 and found the only Completion Behavior item
>> checked by default was "A letter or a digit". This behavior worked as
>> expected. Now that I've also check "A dot and other member selectors"
>> and "A new ...", Resharper does not show the completion list after
>> the dot but does after new. Is this a known issue?
>>

Is this a known issue? I really want my completion lists back.



0
Comment actions Permalink

Yes, it's a know bug with persisting completion options which is
fixed in recent builds.


But it wasn't failing to persist the completion options, it was failing to
show me completion after the dot. When I returned to the Options dialog,
the correct options were retained. Or have I misinterpretted what you've
said? Also, which build contains the fix?


0
Comment actions Permalink

I just upgraded to 455. Completion behavior worked fine at first. After I
did my first F2 renaming, however, I don't get the completion list after
a dot.


0
Comment actions Permalink

I just upgraded to 455. Completion behavior worked fine at first.
After I did my first F2 renaming, however, I don't get the completion
list after a dot.


Oh, that was because the checkbox was unselected after the upgrade. Now that
I've checked it, it works. I'll be quiet now.


0
Comment actions Permalink

Hello,

But it wasn't failing to persist the completion options, it was
failing to show me completion after the dot. When I returned to the
Options dialog, the correct options were retained.


In those builds, the “…after dot” checkbox would mirror the “…after new”
setting.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.