[B2] No Immediate Feedback after Run Unit Tests

I just selected the two failed unit tests and used the Run Unit Tests
command. There was a delay of about seven seconds before the Unit Test
Session window began displaying the green progress circle. During this time
I was wondering if I had really clicked the button...

Please, at least, use a Wait cursor.
--
John


2 comments
Comment actions Permalink

Hello John,

Did it display "Building..." in the unit test status line (right below progress)?
Probably, dependent projects were dirty and required to be built before running
tests.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


JS> I just selected the two failed unit tests and used the Run Unit
JS> Tests command. There was a delay of about seven seconds before the
JS> Unit Test Session window began displaying the green progress circle.
JS> During this time I was wondering if I had really clicked the
JS> button...
JS>
JS> Please, at least, use a Wait cursor.
JS>


0
Comment actions Permalink

"Ilya Ryzhenkov" <orangy@jetbrains.com> wrote in message
news:c8a8a1be13d4c58c9802d090a1be4@news.intellij.net...

Hello John,

>

Did it display "Building..." in the unit test status line (right below
progress)? Probably, dependent projects were dirty and required to be
built before running tests.

>

Sincerely,
Ilya Ryzhenkov


Ilya, I'll keep an eye out for "Building..." the windows were floating, so I
might not have noticed.

--
John


0

Please sign in to leave a comment.