Menus disabled in Version 3.0 Beta2

Hi. I installed Resharper V3.0 Beta2 after deinstalling V3.0 Beta1. Beta1 was working like a charm. Having Beta2 installed most of the menues are disabled. E.g I have no Options Menu; I cannot refactor (Move Types); I have not keyboard shortcuts. What is wrong. I did the installation step by step as described in the docus and resetted VS. I have VS2005 Team Edition SP1 on VISTA Ultimate. I also have the SP1 for VS on Vista installed. Please help!!!

9 comments
Comment actions Permalink

Hello Gabriel,

1) Please make sure that ReSharper is enabled in Tools|Add-In Manager
2) If it is enabled, please try to Reset All Settings (Tools|Import and Export
Settings) and re-open VS.
3) If none of these helps, please try to uninstall the current version of
ReSharper and then re-install it.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Hi. I installed Resharper V3.0 Beta2 after deinstalling V3.0 Beta1.
Beta1 was working like a charm. Having Beta2 installed most of the
menues are disabled. E.g I have no Options Menu; I cannot refactor
(Move Types); I have not keyboard shortcuts. What is wrong. I did the
installation step by step as described in the docus and resetted VS. I
have VS2005 Team Edition SP1 on VISTA Ultimate. I also have the SP1
for VS on Vista installed. Please help!!!



0
Comment actions Permalink

I did check ALL the points mentioned by you before. I reset VS re-installed Resharper but NO luck! I then downloaded build 462 and tried this one. I even manually deleted the Resharper folders in my AppData folder (Roaming and Local) before installing the new build. No luck again.
I can use Resharper but not all functionality (e.g. NO templates, no option menu, etc.) Main Menus that are disabled
- Class
- Interface
- Structure
- Show Tips
- Help
- License Information...
- Product Page
- Submit Feedback...
- About JetBrains ReSharper

I can see NO "Options" Menu any more...

Why did beta 1 work without any limitations?

0
Comment actions Permalink

I further noticed that the ReSharper menus seem be "scrambled". If I use the "Rearrange Commands" option in VS (of "Customize") then I can see that at least the following items make me suspicious sinc they have wrong captions:
ReSharper_ShowOptions --> Class
ReSharper_ShowPlugins --> Interface
ReSharper_ShowLog --> Structure

0
Comment actions Permalink

I now re-installed Beta1 of version 3.0 and again it works! All menus are there.
So...:-( What am I doing wrong with beta2?

0
Comment actions Permalink

Hello Gabriel,

could you please try to re-install the RC build published yesterday? I'd
recommend that you uninstall Beta 1 first (or whatever version of ReSharper
you've installed) and then
install the RC build. Thanks.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


I now re-installed Beta1 of version 3.0 and again it works! All menus
are there. So...:-( What am I doing wrong with beta2?



0
Comment actions Permalink

Hi, I had the same problem. For me the only solution to make Beta2 working was to uninstall all 3.0 versions, install 2.5.2 version and uninstall 2.5.2. Then delete all the folders and install 3.0 again. This time it will work. I had the same behavior on two Vista machines. I have provided logs to JetBrains but they didn't help so far -- they keep on suggesting things that don't work.

David.

PS[1]: http://www.intellij.net/forums/thread.jspa?messageID=5189759&#5189759
PS[2]: Do you have special regional settings on your machine?

0
Comment actions Permalink

It's starting to get annoying!
I deinstalled Beta 1 (which worked correctly) and installed the new release candidate. But the release candidate behaves exactly as beta 2 and the nigtly build I installed before. The menus are messed up again (e.g. no options menu...) and partially disabled.
What can I do? I resume: Beta 1 is working correctly on my machine when I (re-) install it.
I need you help since I like the product and want to continue to use it but I cannot continue like this.

0
Comment actions Permalink

Hi, thanks for your advice. I deinstalled RC of v. 3.0. I deleted any ReSharper specific directories in my profile. I downloaded v. 2.5.5. Since I' a new user of ReSharper I have no license key for version 2.5.2. I tried to install it (JetBrains claims I get a free 30 day evaluation period) but then when starting VS2005 it asks me for a User name and corresponding License Key. If I just cancel the dialog NO ReSharper is available (Note: the OK button of the license dialog is disabled)
What the hell...?!?

0
Comment actions Permalink

Heureka! It works now.
After the advice of David Pokluda (see its response) I deinstalled RC and installed version 2.5.2. Although I could not use it since the license problem it helped to solve my problem! I then deinstalled version 2.5.2 and manually cleaned all ReSharper folders in my profile (local and roaming). I rebooted the computer (just in case...) and installed v.3.0 RC.
When I started VS ReSharper asks how to set the menu shortcuts. This time I NOT to overwrite the menus (normally I choose IDEA). Magically this time ReSharper installed all menus correctly. I then went to the Options menu and set the keyboard shortcuts to "IntelliJ IDEA".
Woaw, what an effort. Hopefully it will help other who have similar problems to find a solution. Possibly you can find the "bug" in your setup such as that such issues will NOT happen in the future.
Any how I am happy now ;)
Gabriel

0

Please sign in to leave a comment.