[560 and before] Starting a Unit Test is a problem

Hi,

hard to find if that problem is allready in JIRA, so i write it here :)

Mostly if i want to start a unit test i get the following Message in the
Output Window

Project not selected to build for this solution configuration

So had i hat to build it manually and then run the unit test. Of course the
TestAssembly is selected to build in the configuration (it doesent matter if
the test assembly is targeted for x86 or AnyCPU).

Also changing the Build Setting in the Runner (Automatic, Always) don't have
an affect.

So that Unit Testing with R# is not so funny as it can be.

Regards

Albert


-


Skipped Build: Project: Jjk.Constants, Configuration: Debug Any
CPU -


Project not selected to build for this solution configuration
-


Skipped Build: Project: JjkLib, Configuration: Debug Any CPU -


Project not selected to build for this solution configuration
-


Skipped Build: Project: JjkObjects, Configuration: Debug Any
CPU -


Project not selected to build for this solution configuration
-


Skipped Build: Project: JjkNUnitExtensions, Configuration: Debug Any
CPU -


Project not selected to build for this solution configuration
-


Skipped Build: Project: Jjk.WebLib, Configuration: Debug Any
CPU -


Project not selected to build for this solution configuration
-


Build started: Project: Jjk.WebLib.Tests, Configuration: Debug Any
CPU -


C:\Windows\Microsoft.NET\Framework\v3.5\Csc.exe /noconfig /nowarn:1701,1702
/errorreport:prompt /warn:4 /define:DEBUG;TRACE
/reference:D:\Code\WebBeilagen\Shared\Jjk.WebLib\bin\Debug\Jjk.WebLib.dll
/reference:D:\Code\WebBeilagen\Shared\JjkLib\bin\Debug\JjkLib.dll
/reference:D:\Code\WebBeilagen\Shared\JjkNUnitExtensions\bin\Debug_RSUmbruch\JjkNUnitExtensions.dll
/reference:..\Vendor\NHibernate\Release\v1.2\NHibernate.dll
/reference:..\Vendor\NUnit\Release\2.4\nunit.framework.dll
/reference:..\Vendor\RhinoMocks\Current\Rhino.Mocks.dll
/reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Data.dll
/reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.dll
/reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Web.dll
/reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Xml.dll
/debug+ /debug:full /optimize- /out:obj\Debug\Jjk.WebLib.Tests.dll
/target:library PresenterInjectorTest.cs Properties\AssemblyInfo.cs
error CS0006: Metadata file
'D:\Code\WebBeilagen\Shared\JjkNUnitExtensions\bin\Debug_RSUmbruch\JjkNUnitExtensions.dll'
could not be found

Compile complete -- 1 errors, 0 warnings
========== Build: 0 succeeded or up-to-date, 1 failed, 5 skipped ==========

1 comment
Comment actions Permalink

Hello Albert,

It looks exactly as if you have different configurations for projects. This
usually happens when you add Web Site to the solution, as it has different
configuration by default. So, could you please verify what you have in Build
| Configuration Manager...? Probably even post screenshot.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


AW> Hi,
AW>
AW> hard to find if that problem is allready in JIRA, so i write it here
AW> :)
AW>
AW> Mostly if i want to start a unit test i get the following Message in
AW> the Output Window
AW>
AW> Project not selected to build for this solution configuration
AW>
AW> So had i hat to build it manually and then run the unit test. Of
AW> course the TestAssembly is selected to build in the configuration
AW> (it doesent matter if the test assembly is targeted for x86 or
AW> AnyCPU).
AW>
AW> Also changing the Build Setting in the Runner (Automatic, Always)
AW> don't have an affect.
AW>
AW> So that Unit Testing with R# is not so funny as it can be.
AW>
AW> Regards
AW>
AW> Albert
AW>
AW> -


Skipped Build: Project: Jjk.Constants, Configuration: Debug
AW> Any
AW> CPU -


AW> Project not selected to build for this solution configuration
AW> -


Skipped Build: Project: JjkLib, Configuration: Debug Any CPU
AW> -


AW> Project not selected to build for this solution configuration
AW> -


Skipped Build: Project: JjkObjects, Configuration: Debug Any
AW> CPU -


AW> Project not selected to build for this solution configuration
AW> -


Skipped Build: Project: JjkNUnitExtensions, Configuration:
AW> Debug Any
AW> CPU -


AW> Project not selected to build for this solution configuration
AW> -


Skipped Build: Project: Jjk.WebLib, Configuration: Debug Any
AW> CPU -


AW> Project not selected to build for this solution configuration
AW> -


Build started: Project: Jjk.WebLib.Tests, Configuration:
AW> Debug Any
AW> CPU -


AW> C:\Windows\Microsoft.NET\Framework\v3.5\Csc.exe /noconfig
AW> /nowarn:1701,1702
AW> /errorreport:prompt /warn:4 /define:DEBUG;TRACE
AW> /reference:D:\Code\WebBeilagen\Shared\Jjk.WebLib\bin\Debug\Jjk.WebLi
AW> b.dll
AW> /reference:D:\Code\WebBeilagen\Shared\JjkLib\bin\Debug\JjkLib.dll
AW> /reference:D:\Code\WebBeilagen\Shared\JjkNUnitExtensions\bin\Debug_R
AW> SUmbruch\JjkNUnitExtensions.dll
AW> /reference:..\Vendor\NHibernate\Release\v1.2\NHibernate.dll
AW> /reference:..\Vendor\NUnit\Release\2.4\nunit.framework.dll
AW> /reference:..\Vendor\RhinoMocks\Current\Rhino.Mocks.dll
AW> /reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Data
AW> .dll
AW> /reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.dll
AW> /reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Web.
AW> dll
AW> /reference:C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Xml.
AW> dll
AW> /debug+ /debug:full /optimize- /out:obj\Debug\Jjk.WebLib.Tests.dll
AW> /target:library PresenterInjectorTest.cs Properties\AssemblyInfo.cs
AW> error CS0006: Metadata file
AW> 'D:\Code\WebBeilagen\Shared\JjkNUnitExtensions\bin\Debug_RSUmbruch\J
AW> jkNUnitExtensions.dll'
AW> could not be found
AW> Compile complete -- 1 errors, 0 warnings
AW> ========== Build: 0 succeeded or up-to-date, 1 failed, 5 skipped
AW> ==========


0

Please sign in to leave a comment.