[745] Ctrl+Del Deletes Too Much

Typically, when I press Ctrl+Del, all whitespace is deleted. I'm not sure when this started happening, but now it deletes all whitespace and a few special characters that might be in the way. For instance, with my cursor at the "|", I expect the following code...

void DoSomething()|
{
...
}

...to change to this, when I press Ctrl+Del...

void DoSomething()|{
...
}

Instead, it's changing to this...

void DoSomething()|...
}

I've looked thru both VS and R# options to see if there's an option that was inadvertantly changed, but there doesn't seem to be one. Has anyone seen this?

FYI - Ctrl+Backspace should have the same expected behavior, but it works correctly.

3 comments
Comment actions Permalink

I found the problem. This only happens when you check the Environment > Editor > Use CamelHumps option.

Still not sure when this was introduced, but it wasn't in 3.0, to the best of my recollection. Any chance on getting this fixed in 4.0?

0
Comment actions Permalink

Didn't mean to mark as answered

0
Comment actions Permalink

Hello,

We appreciate your feedback. The corresponding JIRA request has been created,
and you are welcome to monitor its status at http://www.jetbrains.net/jira/browse/RSRP-60655.

You may want to check our request tracking policy here: http://www.jetbrains.net/confluence/display/ReSharper/ReSharperIssueTracker

Best regards,
- Development Team.


0

Please sign in to leave a comment.