ReSharper Fatal Error in VS2008 Startup

Both builds 755 and 764 display this error when opening VS2008 and the the Resharper addin will not activate (actually, attempting to reactivate it causes the same message).  Is there something I need to do to clean up after an uninstall?
 
 
Regards,
Dan Ruehle
]]>



Attachment(s):
JetBrainsVS2008Error.jpg
4 comments
Comment actions Permalink

After uninstalling and clearing out everything about ReSharper in the registry and finally reinstalling, I still got the same message.  I searched for the GUID in the registry and found this value:
 
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0\Packages\{0C6E6407-13FC-4878-869A-C8B4016C57FE}\SkipLoading
 
Which was set to a value of 1.  I change it and the other package, {40D75537-CE10-4311-A7B0-6B164D80405D}\SkipLoading, value to zero as well and when I started VS2008 after this, I got a prompt for license information.
 
This was using build 764.  I do not believe I removed those packages before uninstalling because they do not have anything in them with the word "ReSharper".
 
Regards,
Dan Ruehle
"Daniel Ruehle" <dan@reallyinc.com> wrote in message news:fsn0ks$uo9$1@is.intellij.net...
Both builds 755 and 764 display this error when opening VS2008 and the the Resharper addin will not activate (actually, attempting to reactivate it causes the same message).  Is there something I need to do to clean up after an uninstall?
 
 
Regards,
Dan Ruehle
]]>



Attachment(s):
JetBrainsVS2008Error.jpg
0
Comment actions Permalink

I don't think that thread applies here. I definately have .Net Framework
3.5 installed and I uninstalled and installed at least 8 times with
different builds to no avail. Each time, I got the same message. The
application worked fine in VS2005, but not VS2008. The installer should
make sure that those registry entries are not left set to 1 causing them not
to load and not allowing the addin to load. I have it fixed now and am not
sure how it got that way in the first place. If I am the only one with this
problem, great, but if it can happen to one, it can happen to many in the
future, at least in my experience.

Regards,
Dan

"t800t8" <no_reply@jetbrains.com> wrote in message
news:6183167.2161206979682643.JavaMail.jive@app4.labs.intellij.net...

Hi Daniel,

>

Check this thread to fix your problem:
http://intellij.net/forums/thread.jspa?threadID=273164&tstart=150


0
Comment actions Permalink

Hi Daniel,

Did you try the trick

"Windows + R (cmd)
devenv /safemode
Wait for VS 2005 / 2008 to load
devenv /setup
Restart VS 2005 / 2008"

?

I don't know why R# 4 works on your VS2005, but not on VS2008. But I have the same error message as yours on VS2008.

0

Please sign in to leave a comment.