775 Strange highlighting colors

I'm noticing some odd highlighting behavior in build 775. Unused using
statements and other suggestions/warnings are showing as standard black text
on a blue background and I don't see the error highlighting at all (e.g. the
red underlines or red squiggles are either invisible or just are being
drawn).


3 comments
Comment actions Permalink

Hello,

I'm noticing some odd highlighting behavior in build 775. Unused using
statements and other suggestions/warnings are showing as standard
black text on a blue background and I don't see the error highlighting
at all (e.g. the red underlines or red squiggles are either invisible
or just are being drawn).


Looks like the Visual Studio highlighting settings have gone mad. With R#
installed, there are over 70 different highlighting settings in total, and
it seems sometimes VS is mixing them up. Usually, just opening the Fons and
Colors VS options page is enough. Resetting the color settings to their defaults
is the last resort.

PS On VS 2005 without SP1, there's a confirmed bug without any workaround
regarding the large number of editor highlighting colors.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

I noticed a similar problem.
When I put the caret over an html line, all the html tags disappear but not the contents or attributes
ex:
content]]>
becomes
href="blablabla" content

then if I move the caret with the arrow keys or start typing they appear again

0
Comment actions Permalink

Thanks for the reminder, Serge. I setup a new development server over the
weekend and hadn't installed Visual Studio 2005 SP1 yet. I just installed
SP1 and highlighting is working as expected.

"Serge Baltic" <baltic@intellij.net> wrote in message
news:dc0986bfc99718ca6ca3c1d84fea@news.intellij.net...

Hello,

>
>> I'm noticing some odd highlighting behavior in build 775. Unused using
>> statements and other suggestions/warnings are showing as standard
>> black text on a blue background and I don't see the error highlighting
>> at all (e.g. the red underlines or red squiggles are either invisible
>> or just are being drawn).
>

Looks like the Visual Studio highlighting settings have gone mad. With R#
installed, there are over 70 different highlighting settings in total, and
it seems sometimes VS is mixing them up. Usually, just opening the Fons
and Colors VS options page is enough. Resetting the color settings to
their defaults is the last resort.

>

PS On VS 2005 without SP1, there's a confirmed bug without any workaround
regarding the large number of editor highlighting colors.

>


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”

>

0

Please sign in to leave a comment.