Resharper 4.0 Live Templates

Hi

I have been having a problem with the live templates since upgrading to R#4, all builds so far

I can select to add a new template, which opens a new "code" window, and I can set the short cut, description and where the template is valid, but I can't enter any text in the code area, although I can post things in.

If I open a template for editing, I can paste things in, but I cannot edit the current template, I get an "Attempted to read or write protected memory error."

This is making using the template editor almost imposible

Also would it be possible to allow the user to sort their templates, I can create a folder in the template window, but I can't find a way to move any templates into the folder.

The latest EAP's have been rearly stable, its great to see the product come togather,

Duncan

10 comments
Comment actions Permalink

Hello Duncan,

If I open a template for editing, I can paste things in, but I cannot
edit the current template, I get an "Attempted to read or write
protected memory error."

That's very strange. Is it possible to catch the access violation in an unmanaged
debugger and post us a callstack/minidump?

Also would it be possible to allow the user to sort their templates, I
can create a folder in the template window, but I can't find a way to
move any templates into the folder.

You can drag&drop templates in the tree to move them around.

WBR,
Oleg Stepanov
Senior Whiteboard Operator
JetBrains, Inc.
"Develop with pleasure!"
mailto:oleg.stepanov@jetbrains.com


0
Comment actions Permalink

"That's very strange. Is it possible to catch the access violation in an unmanaged
debugger and post us a callstack/minidump?"

Yes, please find attached, I had to zip it to get it to upload as it was too big otherwise :)

"You can drag&drop templates in the tree to move them around."

Yep thats what I expected, but it dosn't work, I cannot pick up anyting on the tree view at all!! no errors just nothing happens

Some things of note, I am running 64bit Windows 2003, the tree view is docked to the bottom of the VS screen, and on this system it has never worked!,



Attachment(s):
vsdump.zip
0
Comment actions Permalink

Duncan wrote:
> "That's very strange. Is it possible to catch the access violation
in an unmanaged

debugger and post us a callstack/minidump?"

Yes, please find attached, I had to zip it to get it to upload as it was too big otherwise :)

"You can drag&drop templates in the tree to move them around."

Yep thats what I expected, but it dosn't work, I cannot pick up anyting on the tree view at all!! no errors just nothing happens

Some things of note, I am running 64bit Windows 2003, the tree view is docked to the bottom of the VS screen, and on this system it has never worked!,


I can report I'm having the same issue on 32bit Windows XP - I can paste
in the template but any attempt to edit it results in a error.

I've only tried a few of the latest nightly builds builds but non have
worked so far.

Shannon,

0
Comment actions Permalink

I am also experiencing the same thing.

Duncan wrote:

>> "That's very strange. Is it possible to catch the access violation
>>

in an unmanaged

>> debugger and post us a callstack/minidump?"
>>
>> Yes, please find attached, I had to zip it to get it to upload as it
>> was too big otherwise :)
>>
>> "You can drag&drop templates in the tree to move them around."
>>
>> Yep thats what I expected, but it dosn't work, I cannot pick up
>> anyting on the tree view at all!! no errors just nothing happens
>>
>> Some things of note, I am running 64bit Windows 2003, the tree view
>> is docked to the bottom of the VS screen, and on this system it has
>> never worked!,
>>

I can report I'm having the same issue on 32bit Windows XP - I can
paste
in the template but any attempt to edit it results in a error.
I've only tried a few of the latest nightly builds builds but non have
worked so far.

Shannon,



0
Comment actions Permalink

Hello Duncan,

We have investigated the dump and it seems like some other plugin isn't
ready for our text view. You seem to have a number of plugins installed.
I have discovered some (PowerToys, GhostDoc, TestDriven.NET) and we will
try to recreate the configuration locally. If there are any publicly available
plugins which I haven't listed, please tell us so we can be sure to reproduce
the exact configuration you have.

WBR,
Oleg Stepanov
Senior Whiteboard Operator
JetBrains, Inc.
"Develop with pleasure!"
mailto:oleg.stepanov@jetbrains.com

"That's very strange. Is it possible to catch the access violation in
an unmanaged debugger and post us a callstack/minidump?"

Yes, please find attached, I had to zip it to get it to upload as it
was too big otherwise :)

"You can drag&drop templates in the tree to move them around."

Yep thats what I expected, but it dosn't work, I cannot pick up
anyting on the tree view at all!! no errors just nothing happens

Some things of note, I am running 64bit Windows 2003, the tree view is
docked to the bottom of the VS screen, and on this system it has never
worked!,



0
Comment actions Permalink

Hi

Sorry for the delay, but no all the tools I use are available, in fact I think you listed them all :)

0
Comment actions Permalink

I am still having this problem with the beta release of 4.0 (VS 2005, build
804). If I try to edit a live template, I get an error message alert saying
"Attempted to read or write protected memory". Is anyone else experincing
this?

~Andy

Hi

I have been having a problem with the live templates since upgrading
to R#4, all builds so far

I can select to add a new template, which opens a new "code" window,
and I can set the short cut, description and where the template is
valid, but I can't enter any text in the code area, although I can
post things in.

If I open a template for editing, I can paste things in, but I cannot
edit the current template, I get an "Attempted to read or write
protected memory error."

This is making using the template editor almost imposible

Also would it be possible to allow the user to sort their templates, I
can create a folder in the template window, but I can't find a way to
move any templates into the folder.

The latest EAP's have been rearly stable, its great to see the product
come togather,

Duncan



0
Comment actions Permalink

I'm having the same issue. has this been resolved?

0
Comment actions Permalink

"John Teague" <no_reply@jetbrains.com> schrieb im Newsbeitrag
news:15356585.96591215547963068.JavaMail.jive@app4.labs.intellij.net...

I'm having the same issue. has this been resolved?


Are you using VS 2008 SP1 Beta/.NET 3.5 SP1 Beta?

Regards

Albert

0
Comment actions Permalink

"Albert Weinert" <nimmdieandere@der-albert.com> schrieb im Newsbeitrag
news:g50sdv$1hg$1@is.intellij.net...

"John Teague" <no_reply@jetbrains.com> schrieb im Newsbeitrag
news:15356585.96591215547963068.JavaMail.jive@app4.labs.intellij.net...

>
>> I'm having the same issue. has this been resolved?
>

Are you using VS 2008 SP1 Beta/.NET 3.5 SP1 Beta?


http://www.jetbrains.net/jira/browse/RSRP-73003


Regards

Albert

0

Please sign in to leave a comment.