Code Cleanup

Hi,
How do I stop Code Cleanup automatically inserting regions around
implemented interface members?

Thanks
Jeremy

7 comments

I don't have it in front of me right now, but from what I recall you can control this without much difficulty by editing the type members layout configuration.

0

I don't have it in front of me right now, but from what I recall you
can control this without much difficulty by editing the type members
layout configuration.


You can (add RemoveAllRegions="true" to all the Pattern nodes), but if you
do, re-order type members stops working.


0

Ouch - just looked at it - looks bloody complicated!

"Peter Mounce" <pmounce@narrowstep.com> wrote in message
news:1da99623a2ff8cafa8ffebce92e@news.jetbrains.com...
>> I don't have it in front of me right now, but from what I recall you
>> can control this without much difficulty by editing the type members
>> layout configuration.
>>
>

You can (add RemoveAllRegions="true" to all the Pattern nodes), but if you
do, re-order type members stops working.

>
>

0

Hehe. There's a lot there, but it isn't too bad once you take a few minutes to scroll through it and get a feel for what is in there. This region generation issue should be relatively easy to sort out, as it'll just require turning that off in the interface implementation section of the file.

0

Hi

under options of the resharper menu, click on the Type members layout, and untick the use default patterns this displays what looks like a text file, scroll down its actually a large xml file!!

near the bottom of the file is the interface implementations section, to stop the interface items being contained within regions I commented out the group entry so my section looks like this

<!interface implementations>

0

OK - I'll give it a go .....

"Jeremy Gray" <no_reply@jetbrains.com> wrote in message
news:31729731.96501223913232472.JavaMail.jive@app4.labs.intellij.net...

Hehe. There's a lot there, but it isn't too bad once you take a few
minutes to scroll through it and get a feel for what is in there. This
region generation issue should be relatively easy to sort out, as it'll
just require turning that off in the interface implementation section of
the file.

0

Hi Duncan

That's brilliant - thanks so much - anything to think a little less!!

Actually once I'd copied the file into the XML editor and it got formatted
by the IDE it was a lot easier to see what its about.

No doubt if I play around with this some more I'll manage to completely
bugger up my options

Best regards
Jeremy


"Duncan" <duncan.butler1@btinternet.com> wrote in message
news:16307575.96771223915967395.JavaMail.jive@app4.labs.intellij.net...

Hi

>

under options of the resharper menu, click on the Type members layout,
and untick the use default patterns this displays what looks like a text
file, scroll down its actually a large xml file!!

>

near the bottom of the file is the interface implementations section, to
stop the interface items being contained within regions I commented out
the group entry so my section looks like this

>

<!interface implementations>
<Entry>
<Match>
<And Weight="100">
<Kind Is="member"/>
<ImplementsInterface/>
</And>
</Match>
<Sort>
<ImplementsInterface Immediate="true"/>
</Sort>
<!-- REMOVED SO INTERFACE METHODS ARE NOT SURROUNDED BY A REGION
<Group>
<ImplementsInterface Immediate="true"
Region="$ Members"/>
</Group>
-->
</Entry>

>

Hope this helps

0

Please sign in to leave a comment.