[1530] XAML-Editor hangs

After installing build 1530 i could work for for several hours on some WPF forms with no problem. Then suddenly the XAML-Editor
hangs when i clicked with the mouse on a tag in the editor view. I had to restart Visual Studio. After this the hanngup occurs
nearly each time i try to work with the XAML-Editor it hangs up. Editing C#source is no problem. Before the problem occurs i created
an ObjectDataSource and tried to bind it to a DataGrid on my WPF-Form via drag and drop in the WPF-Editor.

I'm working with VS 2010 Beta 2 on Windows 7 Ultimate 64-Bit. The solution i'm working on is a very small demo app i use for
induction into WPF (just one form and one user control with nearly no code).

Regards
Klaus

3 comments

Hello Klaus
     Have you checked if suspending ReSharper (through Tools > Options > ReSharper > General) fixes this problem? Could you please attach another instance of Visual Studio to the hanging one with debugger, break the execution and gather call stacks for all running threads? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

Hello Andrey,

didn't see that i can disable R# in the Options, so i deinstalled it. Without R# the XAML-Editor works without problems. Unfortunately i have crashed my the MBR of my hard disk this morning and don't have a chance to fix it immediatly because my Windows 7 DVD is at home. When i have fixed my problem i will try to get the stacktraces.

Regards
Klaus

0

It took a long time until i got the error again (i think mainly because i didn't edited XAML code in the last time ).

Meanwhile i'm running build 1541. I'm not sure, if the XAML editor is reaaly the reason for the hangup. VS hangs just after compilation. The active window was as XAML editor window with a resource dictionary with the following code:

<ResourceDictionary xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
                    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
                    xmlns:CustomerViewModel="clr-namespace:PTA.Training.AdventureWorks.Client.ViewModel.Customer"
                    xmlns:CustomerView="clr-namespace:PTA.Training.AdventureWorks.Client.View.Customer"
                    >

  <!-- Bind a CustomerListView to an CustomerListViewModel instance -->
  <DataTemplate DataType="{x:Type CustomerViewModel:CustomerListViewModel}">
    <CustomerView:CustomerListView />
  </DataTemplate>

  <!-- Bind a CustomerDetailView to an CustomerDetailViewModel instance -->
  <DataTemplate DataType="{x:Type CustomerViewModel:CustomerDetailViewModel}">
    <CustomerView:CustomerDetailView />
  </DataTemplate>
  
</ResourceDictionary>


But there where several other XAML windows with user controls open.

I attached another VS instance and tried to get stacktraces but i didn't find any command to get a stacktrace. I tried to get a call stack but this was also not possible because VS was working in external code.

What i've done was a crashdump, but the dump file was 1,2 GB in original and arounf 240 MB compressed. If you could tell me a location where i can upload the dump, i will do so.

I don't know if it will help, but i've attached a screenshot with the running threads at the time the crash occurs.

Regards
Klaus



Attachment(s):
Threadlist.PNG
0

Please sign in to leave a comment.