Error and other warning indicators not showing in code

When I first open a solution in VS 2010 Beta2 and the files open in the
editor, none of the R# (5.0.1552.18) underlining for warnings and errors
appear.  If I then type:

new List().Add();

without a parameter in the Add() method, I get an indicator in the right
margin, f-12 takes me to it and I get a bulb in the left margin, but the
text is not highlighted.

If I save, close and reopen the file, all the colored squiggly
underlines reappear. Are there settings that I don't have set right?

2 comments
Comment actions Permalink

I am now using 5.0.1554.20 and the issue still remains with 2010 Beta2. 
Is anyone else experiencing this?

Richard Haber wrote:

When I first open a solution in VS 2010 Beta2 and the files open in
the editor, none of the R# (5.0.1552.18) underlining for warnings and
errors appear.  If I then type:

>

new List<string>().Add();

>

without a parameter in the Add() method, I get an indicator in the
right margin, f-12 takes me to it and I get a bulb in the left margin,
but the text is not highlighted.

>

If I save, close and reopen the file, all the colored squiggly
underlines reappear. Are there settings that I don't have set right?

0
Comment actions Permalink

Hello Richard,

VS2010 integration is ongoing effort. There are issues in ReSharper and in
VS2010 that makes it a bit weird. We are working with Microsoft on it.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


RH> I am now using 5.0.1554.20 and the issue still remains with 2010
RH> Beta2.  Is anyone else experiencing this?
RH>
RH> Richard Haber wrote:
RH>
>> When I first open a solution in VS 2010 Beta2 and the files open in
>> the editor, none of the R# (5.0.1552.18) underlining for warnings and
>> errors appear.  If I then type:
>>
>> new List


0

Please sign in to leave a comment.