[1577] Naming conventions in structs

I reported an issue in JIRA earlier today in which I noted that ReSharper
isn't suggesting fixes for naming conventions in a nested structure. From
what I can tell so far, it looks as if this may apply to all structs
regardless of nesting.

I also noticed a couple instances in which ReSharper suggested making a
field read-only, but then it didn't prompt to fix the naming convention of
the field (this is in a standard class). In this case it's a protected
internal field and I see the squiggly line, but the quick fix popup has the
items to change or view the settings for the naming rule but not to fix the
naming convention. I pressed Alt+Enter on the item three or four times with
no change, so I fixed a couple other variables then came back to this one.
This time the quick fix worked. I've seen this behavior a couple times today
while refactoring a fairly substantial project, so it's not happening often
by any means.

6 comments
Comment actions Permalink

Hello Greg
     Could you please check if this happens with build #1601 which is available at http://www.jetbrains.net/confluence/display/ReSharper/ReSharper+5.0+Nightly+Builds? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"
0
Comment actions Permalink

I just installed 1602 and I'm still seeing the same issue, but I think I
just found a clue. The suggestion for naming conventions seems to be missing
only in cases in which the struct has
attribute applied. If I remove that attribute from the struct, the fields
have squiggly underlines and the quick fix icon appears.

"Andrey Serebryansky" <no_reply@jetbrains.com> wrote in message
news:15337501.53871264418051425.JavaMail.clearspace@app8.labs.intellij.net...

Hello Greg
     Could you please check if this happens with build #1601 which is
available at
http://www.jetbrains.net/confluence/display/ReSharper/ReSharper5.0Nightly+Builds?
Thank you!

>

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5255158#5255158


0
Comment actions Permalink

I also just noticed that ReSharper is not highlighting items in the
intellisense popup in my unit tests. This is somewhat odd because so far it
seems to happen only when calling Assert.That(...) or Expect(...).

MyMethod(myClassUnderTest.S -- intellisense pops up and highlighting works

Expect(myClassUnderTest.S -- intellisense pops up but doesn't highlight
anything unless I use up/down arrow or click with the mouse

I'm using Visual Studio 2010, NUnit 2.5.3.9345, and both the main project
and the unit test project are C# (.NET Framework 4) class libraries.

"Andrey Serebryansky" <no_reply@jetbrains.com> wrote in message
news:15337501.53871264418051425.JavaMail.clearspace@app8.labs.intellij.net...

Hello Greg
     Could you please check if this happens with build #1601 which is
available at
http://www.jetbrains.net/confluence/display/ReSharper/ReSharper5.0Nightly+Builds?
Thank you!

>

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5255158#5255158


0
Comment actions Permalink

Hello Greg
     I've created a bug-report in our tracker: http://www.jetbrains.net/jira/browse/RSRP-150432 and you're welcome to monitor its status. Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Hello Greg
     Could you please attach a screenshot demonstrating this problem? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

See the attached images. In the first case, I typed Assert.That( and saw two
popups on the screen. Looks like the first popup showing the signature of
the Assert.That method didn't go away. I erased the line and retyped it.
This time I got just the one popup. As you can see, neither of the pictures
is highlighting any of the times in the intellisense popup. In the second
image, the selection box is still around MTAThreadAtrribute.

"Andrey Serebryansky" <no_reply@jetbrains.com> wrote in message
news:8448937.4201264595558203.JavaMail.clearspace@app8.labs.intellij.net...

Hello Greg
     Could you please attach a screenshot demonstrating this problem?
Thank you!

>

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5255386#5255386

0

Please sign in to leave a comment.