Current Line/Column Highlighting in VS2010

I noticed that "current line" highlighting has made its way into the Feb 3
nightly build, along with "current column" highlighting.  Unfortunately, the
standard highlight brush clashes horribly with my color scheme.  Is there a
config file I can edit to change these, and/or turn off just the column
highlighting?  It's playing weird tricks on my eyes :(.

Mike

11 comments
Comment actions Permalink

Hello,

This is the first implementation for Dev10, we're still working on this prototype.
No colors or settings yet, just the ON/OFF checkbox in R# options for the
whole feature.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Hello,

Color selection promoted to the Fonts'n'Colors options page, should get into
build 2010-02-04.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

In my opinion the column highlighting should be abandoned because it draws off the attention to the code. Highlighting the current line as in 4.5 (without gradient) looks much better.

Regards
Klaus

0
Comment actions Permalink

I agree with Klaus--I find the column highlighting distracting.  It was an
interesting idea and worth trying, my verdict is to let it go :).

Mike

"Klaus Luedenscheidt" <no_reply@jetbrains.com> wrote in message
news:24555990.15511265291419783.JavaMail.clearspace@app8.labs.intellij.net...

In my opinion the column highlighting should be abandoned because it draws
off the attention to the code. Highlighting the current line as in 4.5
(without gradient) looks much better.

>

Regards
Klaus

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5255948#5255948


0
Comment actions Permalink

The highlighting is much better now that I can change the highlight color in
VS2010, but I would still like the option to disable the gradient effect, as
well as the column highlighting.  I know this is an early work in progress,
but I wanted to go ahead and state my preferences :).

Cheers,
Mike

"Mike Strobel" <mike.strobel@gmail.com> wrote in message
news:hkc49p$2oo$1@nntp-server.labs.intellij.net...

I noticed that "current line" highlighting has made its way into the Feb 3
nightly build, along with "current column" highlighting.  Unfortunately,
the standard highlight brush clashes horribly with my color scheme.  Is
there a config file I can edit to change these, and/or turn off just the
column highlighting?  It's playing weird tricks on my eyes :(.

>

Mike


0
Comment actions Permalink

How do you change the colors and / or disable the column highlighting feature? I have installed build 5.0.1611.9 in VS2010 and I have the vertical and horizontal cross hair thing turned on and it is driving me nuts. I can't find a checkbox in R# options to turn it off and I don't see a Fonts and Colors item that changes the color? I see other R# fonts and color settings but nothing that appears to change the cross hair color.

Honestly I would prefer to just turn it off completley as it is very annoying to me.


Thanks

0
Comment actions Permalink

Hello,

Try ReSharper / Options / Environment / Editor, Highlight Current Line

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


IR> How do you change the colors and / or disable the column
IR> highlighting feature? I have installed build 5.0.1611.9 in VS2010
IR> and I have the vertical and horizontal cross hair thing turned on
IR> and it is driving me nuts. I can't find a checkbox in R# options to
IR> turn it off and I don't see a Fonts and Colors item that changes the
IR> color? I see other R# fonts and color settings but nothing that
IR> appears to change the cross hair color.
IR>
IR> Honestly I would prefer to just turn it off completley as it is very
IR> annoying to me.
IR>
IR> Thanks
IR>
IR> ---
IR> Original message URL:
IR> http://www.jetbrains.net/devnet/message/5256228#5256228


0
Comment actions Permalink

Yeah I tried that. Didn't seem to work. Tried again it does work now but it seems to not be immediate. I have to shut VS down and open it back up for it to take effect. Maybe having multiple copies of 2010 open at once casued an issue?

0
Comment actions Permalink

Close and reopen files should help. Working on this.


Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


IR> Yeah I tried that. Didn't seem to work. Tried again it does work now
IR> but it seems to not be immediate. I have to shut VS down and open it
IR> back up for it to take effect. Maybe having multiple copies of 2010
IR> open at once casued an issue?
IR>
IR> ---
IR> Original message URL:
IR> http://www.jetbrains.net/devnet/message/5256233#5256233


0
Comment actions Permalink

+1 - I do not like the column highlighting.
In fact, I can't stand it & am forced to turn the whole thing off!
As long as I can turn just column highlighting off, that would be fine.

0
Comment actions Permalink

+1 - Find it irritating too.

0

Please sign in to leave a comment.