Periodic freezing of Resharper as I'm editing

I'm unsure what causes this to start happening but it's very frequent. After a few minutes of editing in VS I will get freezes every 2 seconds or so that last for about a quarter second each.

Going to Tools|Options|Resharper|General and suspending Resharper immediately solves the problem. Resuming Resharper will eventually get the same problem after a few minutes.

This is with 5.1.1708.23.

I assume it's doing something in the background. What can I try disabling that will resolve this?

Scott

9 comments
Comment actions Permalink

Hi

I am experiencing the same.

Actually I have noticed that it happens when the Managed Memory Usage hits 175Mb.

If I restart VS, it works OK, until Managed Memory Usage hits 175Mb again.

And since I hit the limit about every 2 hours, I am restarting VS every 2 hours.

Disabling Resharper helps, but makes my day miserable.

--Jakob

0
Comment actions Permalink

Hello Scott,

Could you please capture some performance snapshots of this behavior following
the instructions at http://confluence.jetbrains.net/display/ReSharper/ReSharperPerformanceProfiling+Instructions
and upload them to ftp://ftp.intellij.net/.uploads/? Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm unsure what causes this to start happening but it's very frequent.
After a few minutes of editing in VS I will get freezes every 2
seconds or so that last for about a quarter second each.

Going to Tools|Options|Resharper|General and suspending Resharper
immediately solves the problem. Resuming Resharper will eventually get
the same problem after a few minutes.

This is with 5.1.1708.23.

I assume it's doing something in the background. What can I try
disabling that will resolve this?

Scott

---
Original message URL:
http://www.jetbrains.net/devnet/message/5265437#5265437



0
Comment actions Permalink

Ok, I uploaded a couple performance profiles (devenv-scottbilas.zip). I'm unsure that I was reproducing this same issue, however. While profiling is enabled it's slowed down enough from normal that I'm not sure if the periodic freezing is actually happening. The periodic freezing may also get lost in the general noise. But devenv was definitely performing much slower than it did without ReSharper enabled.

In the first profile I simply held down the up and down arrow keys and cursored through the file for about 30 seconds. The second one I did the same but also added to it some flipping to different files and back.

Please let me know if you need a better profile, and I'll try to get some more data.

0
Comment actions Permalink

Hello Scott,

Thank you! First of all, try turning off 'Color identifiers' under ReSharper

Options > Code Inspection > Settings. If this doesn't help, try turning

off 'Enable code analysis' as well. Let me know if this helps.

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Ok, I uploaded a couple performance profiles (devenv-scottbilas.zip).
I'm unsure that I was reproducing this same issue, however. While
profiling is enabled it's slowed down enough from normal that I'm not
sure if the periodic freezing is actually happening. The periodic
freezing may also get lost in the general noise. But devenv was
definitely performing much slower than it did without ReSharper
enabled.

In the first profile I simply held down the up and down arrow keys and
cursored through the file for about 30 seconds. The second one I did
the same but also added to it some flipping to different files and
back.

Please let me know if you need a better profile, and I'll try to get
some more data.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5265784#5265784



0
Comment actions Permalink

I have the same problem as the author. The code editor window freezes every second.
I tried to disable either 'Color identifiers' and 'Enable code analysis'. It doesn't help.

0
Comment actions Permalink

Hello,

I have the same problem as the author. The code editor window freezes
every second. I tried to disable either 'Color identifiers' and
'Enable code analysis'. It doesn't help.


Two perf problems related to VS10 editor integration were fixed in 5.1.1.
What's your R# version?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

The build which I am using:

Build 5.1.1727.12 on 2010-07-07T20:40:20

0
Comment actions Permalink

Hello Eugene,

Please upgrade to ReSharper 5.1.1 (build 5.1.1751.8) which is available at
http://www.jetbrains.com/resharper/download/. Let me know if this helps.
Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

The build which I am using:

Build 5.1.1727.12 on 2010-07-07T20:40:20

---
Original message URL:
http://devnet.jetbrains.net/message/5273891#5273891



0
Comment actions Permalink

Seems like update helped. Thanks a lot!
I'll let you know here, if I have any problems again.

0

Please sign in to leave a comment.