Resharper latest build disables Windows 7 Aero Theme

I am running Windows 7 64-Bit, Visual Studio 2010 RC with the two patches installed. Any Build above 5.0.1642.13 when installed stop the aero theme. By that I mean, you launch visual studio then i get an error sayin that Aero theme has reverted back to Windows Basic theme. Now the only thing that is running that may have a conflict would be the DisplayLink Adapters for Dual Screen Monitors but it doesnt happend on the lower build than 1642.13 so I have no idea what could be going on.

22 comments
Comment actions Permalink

i'm currently using build 1653 with the same configruation and don't have the problem even with dual screen (laptop + lcd).

On 10.04.2010 06:05, Bob Marley wrote:

I am running Windows 7 64-Bit, Visual Studio 2010 RC with the two patches installed. Any Build above 5.0.1642.13 when installed stop the aero theme. By that I mean, you launch visual studio then i get an error sayin that Aero theme has reverted back to Windows Basic theme. Now the only thing that is running that may have a conflict would be the DisplayLink Adapters for Dual Screen Monitors.

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5260530#5260530


0
Comment actions Permalink

I'm having the same issue, Resharper 5.0.1659.36, VS 2010 RTM.  It only happens when opening a solution that has a WPF tab already open.  If I close all the WPF tabs, then close VS, when I reopen the solution there's no issue.  If I leave the tab open and open the solution, it reverts to Windows Basic.  Closing the solution doesn't help, but closing VS goes back to Aero theme.

0
Comment actions Permalink

Hello,

Are you sure your video drivers are up-to-date?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Same issue here.
Close a WPF project while designer windows are open. Re-open VS2010 plus WPF project and Windows Aero is disabled.
Doesn't happen if you close all designer windows before closing and reopening the project.

This didn't happen before R# install.

0
Comment actions Permalink

Just FYI, a reboot fixed my issue.  Haven't seen it since.

0
Comment actions Permalink

Thanks for the information. This was after a fresh install and to be fair I hadn't restarted, however, I've just done a reboot and the problem is still there.

0
Comment actions Permalink

This is a problem with Silverlight projects as well. I have basically the same environment mentioned here and experience the same problem.

Same solution - close the XAML/Designer file before exiting Visual Studio. Then, when you restart VS, the Aero theme remains. Forget to close those files before exiting...and it's back to Windows Basic.

And so far, only a single reply from JetBrains? They should release a patch to fix this issue.

0
Comment actions Permalink

Hmm, I'm actually testing this out now on a different development machine at work running Windows 7 Ultimate and it doesn't happen, so it's not an all out fail. It's obviously hardware/driver dependent.

I'll try updating the graphics cards on my laptop later and see if it rectifies the issue. I'll post the results in this thread.

0
Comment actions Permalink

It Still Fails even with Resharper Build 5.1 1700. Getting Kind of annoying. Here are the Steps to replicate

1)Install Display Link Driver http://www.displaylink.com/support/downloads.php
2)Connect Any Monitor that is Display Link Compatible
3)Open VS with Resharper. Create  Silverlight Project Make sure MainPage.xaml is open
4)Close Visual studio but not the tabs
5)Open VIsual studio

Aero theme gets disabled. I dont think this is a DisplayLink issue as it is resharper since dev.exe is what causes the trigger to close Aero. I have the latest Drivers so...

Running Windows 7 64-Bit.

0
Comment actions Permalink

Hello Bob,
What's the model of your video card? What's the version of the drivers on
the 'Driver' tab in the device properties?

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

It Still Fails even with Resharper Build 5.1 1700. Getting Kind of
annoying. Here are the Steps to replicate

1)Install Display Link Driver
http://www.displaylink.com/support/downloads.php
2)Connect Any Monitor that is Display Link Compatible
3)Open VS with Resharper. Create  Silverlight Project Make sure
MainPage.xaml is open
4)Close Visual studio but not the tabs
5)Open VIsual studio
Aero theme gets disabled. I dont think this is a DisplayLink issue as
it is resharper since dev.exe is what causes the trigger to close
Aero. I have the latest Drivers so...

Running Windows 7 64-Bit.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5264461#5264461



0
Comment actions Permalink

Model is GT230M Nividia. Laptop HP dv6-2190us. driver is the latest one on nividia 8.17.11.9716. The latest one

0
Comment actions Permalink

Have exactly the same issue.

Running:

- HP Laptop EliteBook 8530p

- Windows 7 Ultimate x64 with 8GB RAM

- VS 2010 RTM (10.0.30319.1)

- ReSharper 5.1.1727.12

- ATI Mobility Radeon HD 3650 (Driver version: 8.741.0.0 5/27/2010)

Looking like an HP issue?

I can confirm I also have "DisplayLink Core Software" installed

--- EDIT ---

After some more testing I can also confirm the following:

- Uninstalling ReSharper fixes the issue (but obviously, that won't work)

- With VS 2010 still running and in Windows Basic mode, opening an elevated command prompt and doing:

     net stop uxsms

     net start uxsms

  brings Aero back and I'm then able to open other XAML files without it reverting to Windows Basic.

If I then close VS 2010 and reopen the same project, we're back to Windows Basic again.

0
Comment actions Permalink

Hello Jason,

Try disabling 'Automatically adjust visual experience based on client performance'
and 'Use hardware graphics acceleration if possible' alltogether under Tools
| Options | Environment | General. Let me know if this helps. Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Have exactly the same issue.

Running:

  • Windows 7 Ultimate x64

  • 8GB RAM

  • VS 2010 RTM (10.0.30319.1)

  • ReSharper 5.1.1727.12

  • HP Laptop EliteBook 8530p

  • ATI Mobility Radeon HD 3650

Looking like an HP issue?

I can confirm I also have "DisplayLink Core Software" installed

---
Original message URL:
http://devnet.jetbrains.net/message/5267299#5267299



0
Comment actions Permalink

Hi Andrey,

Unfortunately, that did not work.

0
Comment actions Permalink

Solved! (Or at least... a workaround!)

Well, I uninstalled HP USB 2.0 Docking Station Driver (it says something like USB Docking Video in Control Panel) which also uninstalled the DisplayLink Core and now everything is good. So there's something going on with that and ReSharper.

0
Comment actions Permalink

I am having the same problem:

MacBook Pro 17"

Video Card: NVIDIA GeForce 9600M GT

Driver Version: 7.15.11.7756

Resharper Version: 5.0.1659.39

Thanks,

Bob

0
Comment actions Permalink

Just confirmed this is still an issue in build 5.1.1727.12....and it is REALLY annoying!
BW

0
Comment actions Permalink

...and build 5.1.1751.8.

0
Comment actions Permalink

Same here using VS2010 RTM
NVidia NVS 3100 M with 258.96 WHQL
Windows 7 64 Bit
Resharper 5.1.1

0
Comment actions Permalink

Hello Daniel,

Have you tried disabling the 'Automatically adjust visual experience based
on client performance' and 'Use hardware graphics acceleration if available'
options under Tools | Options | Environment | General and restarting Visual
Studio? Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Same here using VS2010 RTM
NVidia NVS 3100 M with 258.96 WHQL
Windows 7 64 Bit
Resharper 5.1.1
---
Original message URL:
http://devnet.jetbrains.net/message/5272859#5272859



0
Comment actions Permalink

Yes I have. I first read the thread and try to follow the threads proposed solutions before contributing to the discussion ;)

Daniel

0
Comment actions Permalink

Look no further for Replica watches,
http://www.replicawatchesi.com/breitling-watches, Replica Watch, http://www.replicawatchesi.com/omega-watches, Swiss Replica Rolex, fake watch, and swiss replica watch. We continuously produce many styles of http://www.replicawatchesi.com/ to ensure that we get the best copy watches for you, such as http://www.replicawatchesi.com/ Watches, Cartier replicas. The http://www.replicawatchesi.com/ Collectors first choice for Quality and Price. Your online resource for high quality Replica Watches. We sale http://www.replicawatchesi.com/tag-heuer-watches at lowest price. Our Replica Tag Heuer Watches are 100% like real ones,Buy Replica Tag Watches and Tag Heuer Replica Watches here.
---
Original message URL: http://devnet.jetbrains.net/message/5282914#5282914

0

Please sign in to leave a comment.