R# 6.0 EAP and Visual Studio 2008 don't work ???

Hello,

i would like to give R# 6.0 EAP a chance on my PC but each nightly build i downloaded until now didn't work. When i load a solution (no matter if it is C# or VB.NET) i get two exceptions with the message "cannot create project with empty guid, location: 'Sonstige Dateien'" (i have reported this several times via the exception reporter). The bulb in the upper right corner of the editor remains gray and shows the tooltip "Analysis will start shortly", nearly all R# menus are grayed out, there is no enhanced syntax highlighting.

I'm working on Windows XP SP3 with Visual Studio 2008 Version 9.0.30729. 1 SP with german locale.

I can't find any reference to "Sonstige Dateien" in my solutions.I  tried to activate "show misc. files in solution explorer" in the VS  options but this didn't help.


Did anyone notice a similar problem?

Regards
Klaus

6 comments

Hello Klaus,

Do I understand correctly that this happens with newly created projects as
well? Also, is it correct that you have a localized (German) Visual Studio
2008? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

http://devnet.jetbrains.net/message/5283699#5283699



0

Hello Andrey,

i just reinstalled EAP build 2078 (i've deinstalled it before because it wa suseless for me) to confirm if the problem also occurs when i create new projects (i always opened existing projects in the past). The problem also occurs on new projects. And yes i use a german localized Version of Visual Studio (which was no problem at all with previous R# versions). I would gladly tell you the issue-numbers i've created in YouTrack, but as YouTrack is down at the moment i can't.

Regards
Klaus

0

i just had the chance to install build 2078 into an english locale Visual Studio 2008. Here it works as expected. While starting the english Visual Studio i noticed that also the "Resharper first run" windows (applying keyboard shortcuts) wasn't shown in the german Visual Studio. Beneath the localization of VS there is another point which may interest you: I don't have administrator privilegs on the PC with the german VS. There i'm only main user. To install R# i patch the MSI with Orca. I delete the two keys "Launch Condition / Privileged" and "Property / ALLUSERS" to be able to run the setup.

Regards
Klaus

0

Hi Andrey,

this issue occures for me also. I already posted that some time ago. Have 
also a german localized version of VS 2008 SP1.
There are a lot of other issues in your bug-tracker. All of then are 
claiming the "Sonstige Dateien" in different languages. I have seen 
russian also.

Please add some priority to this issue. (RSRP-201158)

I can also confirm that it is not working even for new projects.

Thanks,
Lars

On Mon, 17 Jan 2011 10:48:08 +0100, Andrew Serebryansky 
<andrew.serebryansky@jetbrains.com> wrote:

Hello Klaus,

>

Do I understand correctly that this happens with newly created projects 
as well? Also, is it correct that you have a localized (German) Visual 
Studio 2008? Thank you!

>

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> http://devnet.jetbrains.net/message/5283699#5283699
>>
>
>


--
Using Opera's revolutionary email client: http://www.opera.com/mail/

0

Today i did a trick and copied the english locale files from an english VS 2008 installation to my working pc (i can't install VS because my customer don't give me local admin rights). After changing the locale to english in the VS options R# works as expected (tried build 2085)

0

Hello Klaus,

For sure it looks like the problem is related to localized versions of Visual
Studio. We're currently testing R# 6.0 EAP with localized versions of Visual
Studio 2008 on our side. I will write back as soon as we gather more information.
Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Today i did a trick and copied the english locale files from an
english VS 2008 installation to my working pc (i can't install VS
because my customer don't give me local admin rights). After changing
the locale to english in the VS options R# works as expected (tried
build 2085)

---
Original message URL:
http://devnet.jetbrains.net/message/5284465#5284465



0

Please sign in to leave a comment.