Has anyone looked at how much memory VS2010 is using with R# EAP running?

I am seeing upwards of 1GB of RAM usage now. At one point I was pretty stable at around 500 - 600MB. Did something change regarding memory usage?

5 comments

memory usage is always high with R#.

0

Hello,

What build are you using? How big is the managed memory usage reported by
ReSharper in status bar? Also, does Visual Studio consume 1Gb initially after
the solution is opened or it gradually climbs there? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I am seeing upwards of 1GB of RAM usage now. At one point I was pretty
stable at around 500 - 600MB. Did something change regarding memory
usage?

---
Original message URL:
http://devnet.jetbrains.net/message/5298435#5298435



0

It gradually gets there over the course of the day. ReSharper is reporting 228MB currently. According to Task Manager devenv.exe is currently using 1,030,308K. R# is the only addin I am running in VS2010. I am using build 2112

0

Just Restarted VS2010 and it is using 863,024K according to Task Manager so I guess even initial is very high. Just decided to Suspend R# and restart VS2010 again. Without R# devenv.exe is using 435,728K.

0

Today switched to 2116. Memory usage seems stable @751,788K. Better than the >1GB as yesterday with 2112. Noticed 2 things:

(1) I think it might have to do with how many errors you have in your file. I had files where the right panel was all in red ticks and COMPLETELY red because R# was reporting errors that weren't real errors i.e. they weren't errors caught by VS2010. Maybe that has something to do it?

(2) Another thing I noticed is that when the "Error Reporting" circle on the bottom starts blinking red and I don't submit issues the performance gets worse and worse. When I submit all the issues or remove them the performance goes back to normal.

0

Please sign in to leave a comment.