Build 2010 crashing to desktop

Hi

After about 10 minutes VS 2010 with the latest build crashes to the desktop.
If I uninstall it and put on 5.1.3 I have no problems.

I've got the log file - could you please let me have an email address I can send it to?

Many thanks
Jeremy

25 comments

Hello Jeremy,

Please send the logs to me (andrew dot serebryansky at jetbrains dot com).
Could you please also tell us if you have noticed any certain actions that
lead to the crash? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi

After about 10 minutes VS 2010 with the latest build crashes to the
desktop. If I uninstall it and put on 5.1.3 I have no problems.

I've got the log file - could you please let me have an email address
I can send it to?

Many thanks
Jeremy
---
Original message URL:
http://devnet.jetbrains.net/message/5298017#5298017



0

Hi Andrey

Just to let you know - I installed 2011. I've been running it for about two hours and no crashes to the desktop. It still "freezes" intermittently though.

Regards
Jeremy

0

I spoke too soon!

It was working fine for about 4 hours and then started crashing to the desktop again.



Attachment(s):
sshot-1.png
0

Hello Jeremy,

I've looked through the logs, but didn't find anything suspicious. Do you
see any error messages under Control Panel | Administrative Tools | Event
Viewer after Visual Studio crashes? Have you noticed any certain actions
that led to the crash? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I spoke too soon!

It was working fine for about 4 hours and then started crashing to the
desktop again.

---
Original message URL:
http://devnet.jetbrains.net/message/5298143#5298143



0

Hi Andrey,

I reformatted my disk, and did a fresh installation of VS 2010 + SP1.

I installed Resharper EAP.

I then installed the Productivity Power Tools extension.

It ran perfectly well for about 10 hours.

I then tried to change an option on Productivity Power Tools - to remove the NavigationWindow.

VS then crashed.

Tried to open VS and crashed at loading.

I uninstalled Resharper EAP, and VS loads as usual.

I unstalled Productivity Power Tools

VS loads OK

Reinstalled the EAP

VS crashes at loading.

Uninstalled the EAP and reinstalled 5.1.3 VS loads OK


I'm guessing that's its a problem with Productivity Power Tools- but there is no trace of Productivity Power Tools left on my machine, yet there is no way that I can get the EAP to run.

Regards
Jeremy



Attachment(s):
log.txt.zip
0

I can repro this also.  I was a build within the past week and upgraded to 2116 last night on 2 different boxes.  Both instances of VS crash on startup on both boxes now.  If I uninstall the EAP then VS works fine.  On one box I did try 2115 and had the same behavior.  I tried disabling all extensions but that did not help.  I have not uninstalled the extensions (I do have the Productivity Tools installed).  My dev team has 2116 running on boxes on a closed network with the same extensions and we are not experiencing any crashes.

0

I've had to unistall the EAP from my main desktop machine. But its running fine on my notebook which has exactly the same extensions installed.

Jeremy

0

This is happening to me now now with build 2118. Here's the error from event viewer:

Faulting application name: devenv.exe, version: 10.0.40219.1, time stamp: 0x4d5f2a73

Faulting module name: nlssorting.dll, version: 4.0.30319.225, time stamp: 0x4d536715

Exception code: 0xc00000fd

Fault offset: 0x00001121

Faulting process id: 0x2238

Faulting application start time: 0x01cbf0149f2d7cf6

Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe

Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\nlssorting.dll

Report Id: e9c152e7-5c07-11e0-b676-00508d9a3c17

0

Hello Jeremy,

Sorry for delayed response! We're currently looking into this problem and
we'll write back as soon as we can. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I've had to unistall the EAP from my main desktop machine. But its
running fine on my notebook which has exactly the same extensions
installed.

Jeremy

---
Original message URL:
http://devnet.jetbrains.net/message/5298749#5298749



0

Hi Andrey

Bizarre.

I skipped the last few builds having gone back to 5.1.3.

I just installed Build 6.0.2119.39 and VS started up with no crashes!

Not only that but everything feels about 20 times faster! Mind you Ctl-X (Cut) is still fairly slow.

I'll keep going over the weekend with fingers crossed :)

Regards
Jeremy

0

I'm experiencing the same issue on VS 2010 startup (Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\nlssorting.dll). I'm currently on build 2119. I have two Win 7 x64 machines and the problem exists on both. It started one or two builds before that. On one, I had to uninstall R# to get VS 2010 to start up successfully. On the other, it will start intermittently.

0

I'm seeing the same problem with build 2121, the latest available:

Faulting application name: devenv.exe, version: 10.0.40219.1, time stamp: 0x4d5f2a73
Faulting module name: nlssorting.dll, version: 4.0.30319.225, time stamp: 0x4d536715
Exception code: 0xc00000fd
Fault offset: 0x00001460
Faulting process id: 0x1404
Faulting application start time: 0x01cbf2609c3fc645
Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\nlssorting.dll
Report Id: e854bb85-5e53-11e0-8868-68b599f21184

VS2010 crashes to the desktop immediately after starting up.

0

Hello Richard, Ronald and Michael,

Could you please attach WinDbg and when it crashes create a minidump and
attach it here? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm seeing the same problem with build 2121, the latest available:

Faulting application name: devenv.exe, version: 10.0.40219.1, time
stamp: 0x4d5f2a73

Faulting module name: nlssorting.dll, version: 4.0.30319.225, time
stamp: 0x4d536715

Exception code: 0xc00000fd

Fault offset: 0x00001460

Faulting process id: 0x1404

Faulting application start time: 0x01cbf2609c3fc645

Faulting application path: C:\Program Files (x86)\Microsoft Visual
Studio 10.0\Common7\IDE\devenv.exe

Faulting module path:
C:\Windows\Microsoft.NET\Framework\v4.0.30319\nlssorting.dll

Report Id: e854bb85-5e53-11e0-8868-68b599f21184

VS2010 crashes to the desktop immediately after starting up.

---
Original message URL:
http://devnet.jetbrains.net/message/5299174#5299174



0

I uninstalled/re-installed 2121 a couple of times lastnight, and VS2010 crashed each time.

I restarted my computer this morning, and installed 2121 again. This time it works.

0

I had uninstalled R# 6 yesterday so that I could continue working. I installed build 2122 this morning and now it is not crashing. If it starts occurring again on either of my machines, I'll create the minidump and send it to you.

Ron

0

I had this error for the past week.  Mainly on Win 7 x64, but have also seen it happen on WinXP at work.  Usually nlssorting.dll is the mentioned module, tho I've also seen clr.dll at times.

After multiple tries, when even rebooting between installs didn't work, after uninstalling I had to delete all Jetbrains folders in Program Files (x86) and under my user's AppData folders.  Clears all settings I assume, but now VS.NET doesn't crash on startup.

Going to reinstall my extensions and addins now as well; I had tried removing all of them originally thinking there may be a conflict.  But that alone didn't fix it.

Note this happened sometime after build 2116 I believe.  Sorry I didn't get a WinDbg output on it either.

0

For whatever it's worth, I was running arecent version (2119 I think), and I did not have this problem.  But I had another problem that required me to use the VS Command Prompt.  Did you know that the VS Command Prompt depends on C++?  It does.  So I added C++ via the VS Installer.  After that VS crashes at startup every time.  I installed the latest (2123) and same thing.  I have completely uninstalled R#, and no more crashing.  Of course VS running without R# is only slightly bettter than it totally crashing.  Hopefully a fix is coming!

0

I encountered the error today and attached WinDbg to VS 2010 as it was starting up. This is the first time I've used WinDbg so I'm not really sure what I'm doing. However, I saved the output from WinDbg and created two mini-dumps using ProcessExplorer - 2 because there were two instances of VS 2010 running but I think one of them was being used by WinDbg. I've created a 7-zip file with the WinDbg output and minidump and attempted to attached it to this post but I'm encountering a "request to large" error, even though the 7z file is only 10MB. How shall I get it to you?

0

Attached is the WinDbg output. I still can't get the minidump to upload.



Attachment(s):
WinDbg Output.7z.zip
0

This is happening again for me in build 2133. VS2010 immediately crashes after starting up.

I'm installing WinDbg now, but it looks like it's going to take a while.

In the meantime, I uninstalled R#. Which takes me to this page: http://www.jetbrains.com/resharper/uninstall/resharper.jsp?ProductVersion=6.0.2133.35&InstalledVsVersions=10.0  When I submit a comment on that page, I get the following error message:

HTTP Status 500 -


type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception

org.apache.jasper.JasperException: java.lang.NullPointerException
     org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:500)
     org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:428)
     org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
     org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

root cause

java.lang.NullPointerException
     org.apache.jsp.resharper.uninstall.resharper_jsp._jspService(resharper_jsp.java:217)
     org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
     org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:386)
     org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
     org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.32 logs.

0

Update: I installed 2134 this morning, and it's working fine so far.

0

I was using build 2134 all day w/o problems. I decide to restart VS 2010 because it was slowing down. Then when I attempted to start VS 2010 again, I started encountering the crash again. I might be crazy but there's been several times when it works throughout the day and then in the evening it crashes. Could it be related to the time of day? Doesn't make sense to me but that's one observation I've made.

I still have the WinDbg reports, if those are helpful. I've not heard from anyone since offering those.

0

I'm having the same problem with build 2135.  Is there anything I can do to help with this issue?  The same exact build works on a separate machine, but does not work on my laptop.

0

Just had the exact same problem with VS2010 crashing to the desktop upon launch and spent awhile debugging it. Here is the solution that worked for me. Hopefully this information helps Andrey find the root cause...

  1. Open %APPDATA%\Roaming\JetBrains\ReSharper\v6.0\vs10.0\UserSettings.xml.
  2. Search for <Configuration><SettingsComponent><boolean><setting name="SubmitActivityLogs">.
  3. Change the value to False.


If the value is True, VS2010 crashes to the desktop every time. If you set it to False, it doesn't.

I found this by noticing that VS2010 didn't crash under another account even with the same plugins installed. Renaming the %APPDATA% ReSharper directories caused ReSharper to recreate the contents and VS didn't crash. I then copied files over until VS crashed. Deleting UserSettings.xml and launching VS2010 causes ReSharper to recreate the settings. A diff followed by copying differences one-by-one isolated the setting that caused the crash.

0

Please sign in to leave a comment.