VS Enterprise 2015 (Update 2) - Refactor/Navigate menus disabled and shortcuts unavailable

Answered

After updating VS 2015 to Update 2, ReSharper refactors cease to function. The "Refactor" and "Navigate" menus are disabled in both the top menu and context menus. All shortcuts result in the error - "The key combination (...) is bound to command (Resharper_...) which is not currently available"

I've seen suggestions that my cursor focus is on the wrong object or that the key shortcuts need to be remapped. This isn't the case - the ability to refactor is disabled on any solution and in any scenario.

I attempted clearing out %LocalAppData%\JetBrains\Transient\ReSharperPlatformVs14\v05 per the suggestion on post Refactor Menu disabled (VS2015)

This worked, but only very briefly. I was able to use the Refactor menu while the solution was still loading, however, once everything initialized, including ReSharper, the menus are grayed out again. 

Here's what I've tried:

  • Restarted VS / Windows
  • Updated Visual Studio
  • Updated Resharper
  • Repaired Resharper
  • Reset all settings (via Import and Export Settings Wizard)
  • Deleted everything in %LocalAppData%\JetBrains\Transient\ReSharperPlatformVs14\v05
  • Turned off and on solution-wide analysis
  • Cleared R# solution cache

this is what the solution context menu looks like:

 

from the text editor - right-click on a class declaration:

 

here's one of the general shortcut errors:

Lots of errors detected, though the solution builds fine. I can't navigate this link:

My VS 2015 info:

 

3 comments
Comment actions Permalink

Hello Matthew,

Does the issue affect all solutions even a newly created one? Does it affect all projects in the problem solution? 

Thanks! 

0
Comment actions Permalink

The problem was universal and affected new projects as well. 

I'm not sure of the root cause, but it was sometime between installing VS 2015 Update 2 and a recent update to Win 10. I ran a repair on VS 2015 - didn't even have to reinstall ReSharper. Now the problem appears to be resolved. ReSharper tool-tip hints are back, solution-wide analysis isn't flagging false positives and all refactoring options are available from any menu or shortcut keys.

I wish I could have provided a better analysis for anyone having a similar issue in the future, but I believe ultimately my issue was caused by file system corruption from the various update activities. While repairing VS can take a couple of hours to get through, I'd recommend it to recover something like this. 

 

 

0
Comment actions Permalink

Thanks for the update! Glad to hear the issue has been resolved. 

0

Please sign in to leave a comment.