Slow solution loading

Windows 7 x64
ReSharper 6.0.2152.985
VS 2010
AMD Quad-core
4GB RAM

32 project solution (8 web projects, 24 assembly projects)

This is when loading the same solution that had problems building ("Painfully Slow Building in 6.0"). It takes several minutes to load this solution when ReSharper is enabled. Some of this time is spent "Processing Assemblies", but a lot of the waiting occurs before the Solution Explorer appears.

I profiled part of the the loading process (it didn't seem to be making much progress after a few minutes so I stopped it). The profile looks very similar to the profile I took for the build issue. That is, most of the time is spent waiting on a WaitHandle.

I uploaded the profile to: ftp.intellij.net/.uploads/blakel.loading.snapshot.zip

3 comments

Hello Blake,

Thank you! We'll take a look at the snapshot.

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Windows 7 x64
ReSharper 6.0.2152.985
AMD Quad-core
4GB RAM
This is when loading the same solution that had problems building
("Painfully Slow Building in 6.0"). It takes several minutes to load
this solution when ReSharper is enabled. Some of this time is spent
"Processing Assemblies", but a lot of the waiting occurs before the
Solution Explorer appears.

I profiled part of the the loading process (it didn't seem to be
making much progress after a few minutes so I stopped it). The profile
looks very similar to the profile I took for the build issue. That is,
most of the time is spent waiting on a WaitHandle.

I uploaded the profile to:
ftp.intellij.net/.uploads/blakel.loading.snapshot.zip

---
Original message URL:
http://devnet.jetbrains.net/message/5303970#5303970



0

Hello Blake,

Could you please attach a copy of the information from ReSharper | Help |
About dialog? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Windows 7 x64
ReSharper 6.0.2152.985
AMD Quad-core
4GB RAM
This is when loading the same solution that had problems building
("Painfully Slow Building in 6.0"). It takes several minutes to load
this solution when ReSharper is enabled. Some of this time is spent
"Processing Assemblies", but a lot of the waiting occurs before the
Solution Explorer appears.

I profiled part of the the loading process (it didn't seem to be
making much progress after a few minutes so I stopped it). The profile
looks very similar to the profile I took for the build issue. That is,
most of the time is spent waiting on a WaitHandle.

I uploaded the profile to:
ftp.intellij.net/.uploads/blakel.loading.snapshot.zip

---
Original message URL:
http://devnet.jetbrains.net/message/5303970#5303970



0

Here you go:

JetBrains ReSharper 6.0 EAP Full Edition Pre-Release

Build 6.0.2152.985 on 2011-05-23T09:31:02

Free evaluation 17 days left

Plugins: none

Visual Studio 10.0.30319.1.

Copyright © 2003–2011 JetBrains s.r.o. All rights reserved.

0

Please sign in to leave a comment.