Intellisense misbehavior

first, the latest builds are quite good. No exceptions anymore, perfomance is acceptable. But there is one thing i always stumble over:

I define a new class in namespace A. Then i want to use this class in namespace b. I didn't add a using for namespace A in my source. When i start to type the classname intellisense pops up and makes suggestions. Because i didn't imported namespace A until now, my newly defined class is not in the suggestion list. When i press space after entering the complete classname i expect that the "Add Using" fix will be displayed. Instead my class was replaced by the entry from the suggestion list which was higkighted at the time i completed to entry the class name. When i close the suggestion popup manually via escape before finisch entering my classname, the "Add Using" fix will be displayed.

I hope you will fix this behavior before the release build, it's absolute annoying.

Regards
Klaus

4 comments

Hello Klaus,

At the moment this behavior is by design. In order to avoid this behavior
you can either:
1. Close the completion list with Esc without pressing Enter or Space in
order to avoid inserting the currently selected item in the code completion
list
2. Use ReSharper | Edit | Import Symbol (or the corresponding shortcut)

Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

first, the latest builds are quite good. No exceptions anymore,
perfomance is acceptable. But there is one thing i always stumble
over:

I define a new class in namespace A. Then i want to use this class in
namespace b. I didn't add a using for namespace A in my source. When i
start to type the classname intellisense pops up and makes
suggestions. Because i didn't imported namespace A until now, my newly
defined class is not in the suggestion list. When i press space after
entering the complete classname i expect that the "Add Using" fix will
be displayed. Instead my class was replaced by the entry from the
suggestion list which was higkighted at the time i completed to entry
the class name. When i close the suggestion popup manually via escape
before finisch entering my classname, the "Add Using" fix will be
displayed.

I hope you will fix this behavior before the release build, it's
absolute annoying.

Regards
Klaus
---
Original message URL:
http://devnet.jetbrains.net/message/5307087#5307087



0

it's a pity that the behavior is by design. I try to remember that i should use ESC to close the popup, but most time i forget it. I hope you will redesign the popup behavior as soon as possible.

Regards
Klaus

0

Hi Claus.
Am I right that the source of your problem in automatic item completion on typing space? I've heard complains about this behavior many times. By 6.1 I'm going to develop an alternative approach to handling typing in completion popup that should fix this and similar issues. Please let us know if you have any other suggestion)
PS
Unfortunately it's out of 6.0 scope. We really have to think over various use cases for different technologies. Thanks for understanding.

0

Hello Sergey,

Am I right that the source of your problem in automatic item completion on typing space?


you are right. Am i right that you try to correct typing errors with this behavior? You deserve credits for trying this, but in my opinion it is not necessary.

My preferred way to fix this would be to complete only automatically if all characters i typed are part of the item. The popup should disappear when i type the first character which is not part of any item in the list.

2011-06-27 05h22_20.png
In this example screenshot the popup should disappear when i type the "n" .

When i type a declaration R# should also check if i'm typing the name of a class which is contained in a namespace i haven't included (as it do now only if i press ESC to close the popup).

Is it possible to make a workaround by adding an option which restricts  automatic item completion by typing TAB? If i remember this was the  behavior in R# 5.x.

Regards
Klaus

0

Please sign in to leave a comment.