[2155]DeploymentItems and DataSource attributes are not working when using TestRunner

I have several unit tests within a test class and unit test project (MSTest).

Several of these unit tests have the datasource attribute assigned to an xml file that I have marked using the deploymentitem attribute.  Unfortunately when I run these test using the resharper test runner (6.0 EAP). These test fail with an exception
"The unit test adapter failed to connect to the data source or to read the data. For more information on troubleshooting this error, see "Troubleshooting Data-Driven Unit Tests" (http://go.microsoft.com/fwlink/?LinkId=62412) in the MSDN Library.
Error details: Object reference not set to an instance of an object."

This also happens if I simply set deployment items within the testconfig for the whole project/solution.  I get the same error.

However with the same unit tests being run under the VSTS test runner there are no issues. and the tests run as expected.

Anyone else seen this behavior or have any insight as to what could be causing this (I am sure I have something configured wrong).

For reference my resharper unit test settings are Project Output folder and Shadow Copying is disabled.  I have recieved the error with shadow copying on as well.

Thanks again.

3 comments

I have the same issue
Build 6.0.2202.688

0

I have the same issue as well.
Build 6.0.2202.688

0

Hello,

This problem should get fixed in ReSharper 6.1. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have the same issue as well.
Build 6.0.2202.688
---
Original message URL:
http://devnet.jetbrains.net/message/5320272#5320272



0

Please sign in to leave a comment.