Auto closing brace does not disable

I can't seem to get the Auto brace function to disable itself. I've
disabled it in Coderush, so there is no conflict anymore, but even with
coderush uninstalled I am unable to completely disable the auto insert
closing brace feature regardless of the option I choose in the Resharper
options panel. I've tried both the 1.5 final and the latest build.

Jesse Houwing

5 comments
Comment actions Permalink

Hello Jesse,

Setting "Auto insert of close brace" from ReSharper/Options/Editor to "Do
not insert" works for me. Does the insertion mode change if you select "On
typing open brace" or "On Enter after open brace"?

I can't seem to get the Auto brace function to disable itself. I've
disabled it in Coderush, so there is no conflict anymore, but even
with coderush uninstalled I am unable to completely disable the auto
insert closing brace feature regardless of the option I choose in the
Resharper options panel. I've tried both the 1.5 final and the latest
build.

Jesse Houwing

Thanks,
Andrey Simanovsky


0
Comment actions Permalink

Andrey Simanovsky (JetBrains) wrote:

Hello Jesse,

Setting "Auto insert of close brace" from ReSharper/Options/Editor to
"Do not insert" works for me. Does the insertion mode change if you
select "On typing open brace" or "On Enter after open brace"?


It happens regardless of the setting chosen.

And with Coderush activated I get two closing braces. Disabling coderush
auto brace completeion results in one brace, but disabling resharper
brace completion (or chosing a different setting for that matter) does not.

I've uninstalled resharper and tested with just coderush: all ok
I've uninstalled coderush and tested with just resharper: always a
closing brace.

Jesse

>> I can't seem to get the Auto brace function to disable itself. I've
>> disabled it in Coderush, so there is no conflict anymore, but even
>> with coderush uninstalled I am unable to completely disable the auto
>> insert closing brace feature regardless of the option I choose in the
>> Resharper options panel. I've tried both the 1.5 final and the latest
>> build.
>>
>> Jesse Houwing
>>

Thanks,
Andrey Simanovsky

0
Comment actions Permalink

Hello Jesse,

Sorry for a delay in responding.
Could you look into ReSharper user settings file. It is usually located somewhere
at C:\Documents and Settings\]]>\Application Data\JetBrains\ReSharper\UserSettings.xml.
What is the value of element with attribute name="smartBraceInsert"? If you
set it manually to 0 before starting ReSharper is the brace still inserted?

Andrey Simanovsky (JetBrains) wrote:

>> Hello Jesse,
>>
>> Setting "Auto insert of close brace" from ReSharper/Options/Editor to
>> "Do not insert" works for me. Does the insertion mode change if you
>> select "On typing open brace" or "On Enter after open brace"?
>>

It happens regardless of the setting chosen.

And with Coderush activated I get two closing braces. Disabling
coderush auto brace completeion results in one brace, but disabling
resharper brace completion (or chosing a different setting for that
matter) does not.

I've uninstalled resharper and tested with just coderush: all ok I've
uninstalled coderush and tested with just resharper: always a closing
brace.

Jesse

>>> I can't seem to get the Auto brace function to disable itself. I've
>>> disabled it in Coderush, so there is no conflict anymore, but even
>>> with coderush uninstalled I am unable to completely disable the auto
>>> insert closing brace feature regardless of the option I choose in
>>> the Resharper options panel. I've tried both the 1.5 final and the
>>> latest build.
>>>
>>> Jesse Houwing
>>>
>> Thanks,
>> Andrey Simanovsky
Thanks,
Andrey Simanovsky


0
Comment actions Permalink

Hello Jesse,

Just an update: it might be that user settings file got corrupted. It looks
like ReSharper uses default values for all settings.

Hello Jesse,

Sorry for a delay in responding.

Could you look into ReSharper user settings file. It is usually
located somewhere

at C:\Documents and Settings\<your user name>\Application
Data\JetBrains\ReSharper\UserSettings.xml.

What is the value of element with attribute name="smartBraceInsert"?
If you

set it manually to 0 before starting ReSharper is the brace still
inserted?

>> Andrey Simanovsky (JetBrains) wrote:
>>
>>> Hello Jesse,
>>>
>>> Setting "Auto insert of close brace" from ReSharper/Options/Editor
>>> to "Do not insert" works for me. Does the insertion mode change if
>>> you select "On typing open brace" or "On Enter after open brace"?
>>>
>> It happens regardless of the setting chosen.
>>
>> And with Coderush activated I get two closing braces. Disabling
>> coderush auto brace completeion results in one brace, but disabling
>> resharper brace completion (or chosing a different setting for that
>> matter) does not.
>>
>> I've uninstalled resharper and tested with just coderush: all ok I've
>> uninstalled coderush and tested with just resharper: always a closing
>> brace.
>>
>> Jesse
>>
>>>> I can't seem to get the Auto brace function to disable itself. I've
>>>> disabled it in Coderush, so there is no conflict anymore, but even
>>>> with coderush uninstalled I am unable to completely disable the
>>>> auto insert closing brace feature regardless of the option I choose
>>>> in the Resharper options panel. I've tried both the 1.5 final and
>>>> the latest build.
>>>>
>>>> Jesse Houwing
>>>>
>>> Thanks,
>>> Andrey Simanovsky

Thanks,
Andrey Simanovsky

Thanks,
Andrey Simanovsky


0
Comment actions Permalink

Andrey Simanovsky (JetBrains) wrote:

Hello Jesse,

Sorry for a delay in responding.
Could you look into ReSharper user settings file. It is usually located
somewhere at C:\Documents and Settings\<your user name>\Application
Data\JetBrains\ReSharper\UserSettings.xml. What is the value of element
with attribute name="smartBraceInsert"? If you set it manually to 0
before starting ReSharper is the brace still inserted?


Did a fresh install (some old bootsector virus completely killed my NTFS
partitions, Norton did nothing to prevent it ;(

I'm not seeing the "smartBraceInsert" at all in the usersettings.xml
file. Hmm just started-up VS again and changed the setting. It now
appeared, but ir's still not working correctly.

It only seems to work incorrectly if the Resharper intellisense option
is active. Setting it to VS intellisense fixes the issues.

Jesse

>> Andrey Simanovsky (JetBrains) wrote:
>>
>>> Hello Jesse,
>>>
>>> Setting "Auto insert of close brace" from ReSharper/Options/Editor to
>>> "Do not insert" works for me. Does the insertion mode change if you
>>> select "On typing open brace" or "On Enter after open brace"?
>>>
>> It happens regardless of the setting chosen.
>>
>> And with Coderush activated I get two closing braces. Disabling
>> coderush auto brace completeion results in one brace, but disabling
>> resharper brace completion (or chosing a different setting for that
>> matter) does not.
>>
>> I've uninstalled resharper and tested with just coderush: all ok I've
>> uninstalled coderush and tested with just resharper: always a closing
>> brace.
>>
>> Jesse
>>
>>>> I can't seem to get the Auto brace function to disable itself. I've
>>>> disabled it in Coderush, so there is no conflict anymore, but even
>>>> with coderush uninstalled I am unable to completely disable the auto
>>>> insert closing brace feature regardless of the option I choose in
>>>> the Resharper options panel. I've tried both the 1.5 final and the
>>>> latest build.
>>>>
>>>> Jesse Houwing
>>>>
>>> Thanks,
>>> Andrey Simanovsky


Thanks,
Andrey Simanovsky

0

Please sign in to leave a comment.