problem with color highlighting

Hello,

I have a strange problem : I have lost keyword color highlighting (keywords are in black instead of blue) ; resharper still works.
This problem doesn't occur for classes that inherit from System.Windows.Forms.Form
I have repaired VS.NET and reinstalled resharper...
any idea ??

JC

6 comments
Comment actions Permalink

Something similar has actually been discussed in the Thread before (Colors of Brackets werent set right)

http://intellij.net/forums/thread.jsp?forum=59&thread=144031&tstart=0&trange=30

it apparently has something to do with some registry keys defining the External VS Markers (Colors)
it's in:

HKLM\Software\Microsoft\VisualStudio\7.1\Text Editor\External Markers

maybe try deleting those and reinstall resharper?

0
Comment actions Permalink

I've removed the keys, re-installed resharper but I have the same problem.
I can change the keyword color (in Options-Font and Colors), then the color is changed in my WinForms, but other classes display keywords in black...

0
Comment actions Permalink

Hello JC,

please answer the following questions:

1) Do you observe the problem with any solution?

2) Does keyword highlighting work correctly with other languages (e.g. Visual
Basic)?

3) If you disable ReSharper (Tools | Add-In Manager), does this make any
difference?

Thanks.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I've removed the keys, re-installed resharper but I have the same
problem.

I can change the keyword color (in Options-Font and Colors), then the
color is changed in my WinForms, but other classes display keywords in
black...



0
Comment actions Permalink

1) Do you observe the problem with any solution?
Yes

2) Does keyword highlighting work correctly with other languages (e.g. Visual Basic)?
Yes

3) If you disable ReSharper (Tools | Add-In Manager), does this make any difference?
No

And keyword highlighting works correctly if my class inherits from Form, UserControl... (so if there is a designer), very strange...

0
Comment actions Permalink

Hello JC,

most likely you still have a problem with Visual Studio configuration. I've
never heard
about such an issue though. Another thing I can recommend is to run
'devenv.exe /setup' - this sometimes helps to resolve similar problems.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

1) Do you observe the problem with any solution? Yes

2) Does keyword highlighting work correctly with other languages (e.g.
Visual Basic)? Yes

3) If you disable ReSharper (Tools | Add-In Manager), does this make
any difference? No

And keyword highlighting works correctly if my class inherits from
Form, UserControl... (so if there is a designer), very strange...



0
Comment actions Permalink

I have re-re-installed VS.NET and now it works. Strange bug...

0

Please sign in to leave a comment.