Problems w/ R# after installation

Hi,

I'm having some problems all of a sudden w/ R#. I uninstalled a couple old
versions of 3rd party components (nothing out of the norm from what i've
done before) and now, when I load an existing project, all the
intellisense don't work. Specifically, ALL the namespaces are showing that
they can't be resolved. References are updated appropriately and the
application will compile and run w/o problem. When i uninstall R#,
everything is fine, but when i reinstall still having the problems.

I downloaded and installed the latest version (1.5.1) and having the
problem. I've tried this twice. Any ideas how to solve this?

Doug


6 comments
Comment actions Permalink

Same problems here using build 207. Uninstalled already. Waiting for the new build.

0
Comment actions Permalink

Hello Doug,

try the following in the specified order:

1) Remove ReSharper's solution caches - located in the "_ReSharper" subdirectory
of the solution directory
1) Remove ReSharper's system caches - they're normally located at \Documents
and Settings\]]>\Application Data\JetBrains\ReSharper\
2) If the previous does not help, repair your VS.NET installation. This means
that uninstallation of a 3rd
party component broke VS.NET by unregistering some VS COM servers. ReSharper
no longer receives notifications
about certain user events, and this manifests itself as numerous unresolved
references.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I'm having some problems all of a sudden w/ R#. I uninstalled a
couple old versions of 3rd party components (nothing out of the norm
from what i've done before) and now, when I load an existing
project, all the intellisense don't work. Specifically, ALL the
namespaces are showing that they can't be resolved. References are
updated appropriately and the application will compile and run w/o
problem. When i uninstall R#, everything is fine, but when i
reinstall still having the problems.

I downloaded and installed the latest version (1.5.1) and having the
problem. I've tried this twice. Any ideas how to solve this?

Doug



0
Comment actions Permalink

Hello CFQueb,

could you please elaborate on your problems? If they are of the same kind
as those of the original poster,
new ReSharper build will not be a remedy. Please read my reply to his post.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Same problems here using build 207. Uninstalled already. Waiting for
the new build.



0
Comment actions Permalink

Hello Dmitry,

Thank you for your reply.

The steps followed in your reply to Doug were followed but like i said in my last post but the problems persevere, deleting the temporal files for some unknowed reason "hang" my application can't to run again, for this reason i have uninstalled Resharper 2 build 207 and i'm waiting for the new release.

PS.

Now that i remember and that you say in your last reply to Doug, the last application that i installed was CodeRush v1.1.32 (in trial mode, but like the plugins does not works expired-, i uninstall this application.).

Uninstalling ReSharper (_was the last application that i uninstall_) my applications can run again.

Regards

0
Comment actions Permalink

**sigh**

I will try the steps. Fingers crossed that #2 isn't necessary - takes WAY
TOO LONG to uninstall / deregister everything and reinstall. For the record
though, again, this has NOTHING to do w/ 2.0. This computer did not have a
2.0 R# installation (ever).

dh
"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d987ad68c79d34568f7360@news.intellij.net...

Hello Doug,

>

try the following in the specified order:

>

1) Remove ReSharper's solution caches - located in the "_ReSharper"
subdirectory of the solution directory
1) Remove ReSharper's system caches - they're normally located at
\Documents and Settings\<user>\Application Data\JetBrains\ReSharper\
2) If the previous does not help, repair your VS.NET installation. This
means that uninstallation of a 3rd
party component broke VS.NET by unregistering some VS COM servers.
ReSharper no longer receives notifications
about certain user events, and this manifests itself as numerous
unresolved references.

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Hi,
>>
>> I'm having some problems all of a sudden w/ R#. I uninstalled a
>> couple old versions of 3rd party components (nothing out of the norm
>> from what i've done before) and now, when I load an existing
>> project, all the intellisense don't work. Specifically, ALL the
>> namespaces are showing that they can't be resolved. References are
>> updated appropriately and the application will compile and run w/o
>> problem. When i uninstall R#, everything is fine, but when i
>> reinstall still having the problems.
>>
>> I downloaded and installed the latest version (1.5.1) and having the
>> problem. I've tried this twice. Any ideas how to solve this?
>>
>> Doug
>>
>



0
Comment actions Permalink

oh joy!!!! oh happiness it works!!!! i didn't have to do step #2; big sigh
of relief.

Cheers Dmitry
"Doug Handler" <dkhandler@yahoo.com> wrote in message
news:dik5ge$6ot$1@is.intellij.net...

**sigh**

>

I will try the steps. Fingers crossed that #2 isn't necessary - takes WAY
TOO LONG to uninstall / deregister everything and reinstall. For the
record though, again, this has NOTHING to do w/ 2.0. This computer did
not have a 2.0 R# installation (ever).

>

dh
"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d987ad68c79d34568f7360@news.intellij.net...

>> Hello Doug,
>>
>> try the following in the specified order:
>>
>> 1) Remove ReSharper's solution caches - located in the "_ReSharper"
>> subdirectory of the solution directory
>> 1) Remove ReSharper's system caches - they're normally located at
>> \Documents and Settings\\Application Data\JetBrains\ReSharper\ >> 2) If the previous does not help, repair your VS.NET installation. This >> means that uninstallation of a 3rd >> party component broke VS.NET by unregistering some VS COM servers. >> ReSharper no longer receives notifications >> about certain user events, and this manifests itself as numerous >> unresolved references. >> >> Regards, >> Dmitry Shaporenkov >> JetBrains, Inc >> http://www.jetbrains.com >> "Develop with pleasure!" >> >>> Hi, >>> >>> I'm having some problems all of a sudden w/ R#. I uninstalled a >>> couple old versions of 3rd party components (nothing out of the norm >>>]]> from what i've done before) and now, when I load an existing
>>> project, all the intellisense don't work. Specifically, ALL the
>>> namespaces are showing that they can't be resolved. References are
>>> updated appropriately and the application will compile and run w/o
>>> problem. When i uninstall R#, everything is fine, but when i
>>> reinstall still having the problems.
>>>
>>> I downloaded and installed the latest version (1.5.1) and having the
>>> problem. I've tried this twice. Any ideas how to solve this?
>>>
>>> Doug
>>>
>>
>>
>



0

Please sign in to leave a comment.