Installation Issue: Error 1721

hi, i keep getting error 1721 from the installer when i try to install the latest version of resharper (build 232). The operating system is Windows 2003 R2 and the Visual Studio is 2005 version. I have attached the installer log file to aid in troubleshooting this issue.

Thanks



Attachment(s):
Resharper.zip
10 comments
Comment actions Permalink

Hello z4ck,

please close all instances of VS and try running 'devenv /setup' from the
command line. The log indicates that this commands fail, and this is the
reason of the installation failure.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

hi, i keep getting error 1721 from the installer when i try to install
the latest version of resharper (build 232). The operating system is
Windows 2003 R2 and the Visual Studio is 2005 version. I have attached
the installer log file to aid in troubleshooting this issue.

Thanks



0
Comment actions Permalink

Ok, i have tried that. When i go to Start>Run and type in devenv /setup, it works fine but when i type D:\Program Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe /setup as it is shown in the log file, i get a 'Open With' box pop up asking me what application i want to use. It has the file named 'Program' showing as the file it is trying to open. The installer is still failing.

I look forward to a response.

0
Comment actions Permalink

Hello z4ck,

not sure I undertand completely, but can you simple change the current directory
to the
"D:\Program Files\Microsoft Visual Studio 8\Common7\IDE\" and run 'devenv
/setup' in this directory?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Ok, i have tried that. When i go to Start>Run and type in devenv
/setup, it works fine but when i type D:\Program Files\Microsoft
Visual Studio 8\Common7\IDE
devenv.exe /setup as it is shown in the
log file, i get a 'Open With' box pop up asking me what application i
want to use. It has the file named 'Program' showing as the file it is
trying to open. The installer is still failing.

I look forward to a response.



0
Comment actions Permalink

Doing the above works..heres what i mean:

C:\>D:\Program Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe /setup
'D:\Program' is not recognized as an internal or external command,
operable program or batch file.

The above does not work if i use the full path name to execute the devenv /setup

If i do:

D:\Program Files\Microsoft Visual Studio 8\Common7\IDE>devenv.exe /setup

it works fine. I have a feeling some configuration on my machine is cause the 1st approach to fail which is why the installer fails as well. The installer seems to be trying the first approach to trigger the devenv /setup command which fails.

0
Comment actions Permalink

Hello z4ck,

please enclose path to the devenv.exe in quotes like this:
"D:\Program Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe".

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Doing the above works..heres what i mean:

C:\>D:\Program Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe
/setup
'D:\Program' is not recognized as an internal or external command,
operable program or batch file.
The above does not work if i use the full path name to execute the
devenv /setup

If i do:

D:\Program Files\Microsoft Visual Studio 8\Common7\IDE>devenv.exe
/setup

it works fine. I have a feeling some configuration on my machine is
cause the 1st approach to fail which is why the installer fails as
well. The installer seems to be trying the first approach to trigger
the devenv /setup command which fails.



0
Comment actions Permalink

X:\>"D:\Program Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe" /setup works. The installer does not launch the devenv /setup with the quotes thus it fails. Could an updated build with a fixed installer be released where the installer actually uses quotes when it tries to fire the devenv /setup command. Currently i believe the installer is just doing a D:\Program Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe /setup without the quotes.

0
Comment actions Permalink

Hello z4ck,

if it were the case, the installer would fail on 99% of user machines, as
almost anyone
has VS in the 'Program Files' (with spaces in the name) folder. Please try
to run the installer
as follows 'ReSharper-XX.exe /V"/lvx log.txt"', and post here the resulting
log file 'log.txt'. Thanks.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

X:\>"D:\Program Files\Microsoft Visual Studio
8\Common7\IDE
devenv.exe" /setup works. The installer does not launch
the devenv /setup with the quotes thus it fails. Could an updated
build with a fixed installer be released where the installer actually
uses quotes when it tries to fire the devenv /setup command. Currently
i believe the installer is just doing a D:\Program Files\Microsoft
Visual Studio 8\Common7\IDE
devenv.exe /setup without the quotes.



0
Comment actions Permalink

Oops, sorry, I've forgotten that you has already done this in the very first
post to this thread.
Could you please then try the following:

1) Run installer
2) Wait for the error dialog to appear, but don't react to it (otherwise,
the rollback process will be
triggered)
3) Having the error dialog displayed, please try to run 'devenv /setup' as
we discussed above. This should
give us an opportunity to see what happens when this command runs during
the installation.

Thanks.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello z4ck,

if it were the case, the installer would fail on 99% of user machines,
as
almost anyone
has VS in the 'Program Files' (with spaces in the name) folder. Please
try
to run the installer
as follows 'ReSharper-XX.exe /V"/lvx log.txt"', and post here the
resulting
log file 'log.txt'. Thanks.
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> X:\>"D:\Program Files\Microsoft Visual Studio
>> 8\Common7\IDE
devenv.exe" /setup works. The installer does not
>> launch the devenv /setup with the quotes thus it fails. Could an
>> updated build with a fixed installer be released where the installer
>> actually uses quotes when it tries to fire the devenv /setup command.
>> Currently i believe the installer is just doing a D:\Program
>> Files\Microsoft Visual Studio 8\Common7\IDE
devenv.exe /setup
>> without the quotes.
>>


0
Comment actions Permalink

i just tried with build 233 and it just worked. No errors this time. I guess something changed in the installer which made it work :)

0
Comment actions Permalink

Hello z4ck,

no, there were no changes to the installer in recent builds. But I'm glad
that it works for you now.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

i just tried with build 233 and it just worked. No errors this time. I
guess something changed in the installer which made it work :)



0

Please sign in to leave a comment.